Announcement

Collapse
No announcement yet.

Invalid File Error while uploading avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid File Error while uploading avatars

    Users cannot upload avatars. When they try, they receive the error "Invalid file"
    I'm running 3.6.4
    It appears that my webhost has safe mode set to off.

    Any ideas?

  • #2
    What happens if you run the upload diagnostics test (in ACP > Maintenance > Diagnostics)
    Baby, I was born this way

    Comment


    • #3
      Originally posted by Paul M View Post
      What happens if you run the upload diagnostics test (in ACP > Maintenance > Diagnostics)
      Pertinent PHP Settings file_uploads:On
      open_basedir:None
      safe_mode:Off
      upload_tmp_dir:None
      upload_max_filesize:7.00 MB

      Results No errors occurred while opening the uploaded file for reading. You should be able to turn off the "Upload In Safe Mode?" option without any adverse effects.

      Comment


      • #4
        Turn off the Upload in Safemode option and try again.

        Comment


        • #5
          I set the safemode upload to No in Server Settings and Optimization Options and I'm still getting the error.

          Comment


          • #6
            WHat sort of file are you trying to upload, can you attach it here?

            Comment


            • #7
              Attached
              Attached Files

              Comment


              • #8
                Do you allow animated avatars for your users?

                Comment


                • #9
                  Originally posted by Zachery View Post
                  Do you allow animated avatars for your users?
                  Yes, and it doesn't work for regular image files too.

                  Comment


                  • #10
                    The only thing I see that could cause this is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 777.

                    You will also need to restart Apache after making this change.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X