Announcement

Collapse
No announcement yet.

registration error, help please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • registration error, help please

    now when anyone tries to register on my site i am getting this error:

    Database error in vBulletin 3.6.2:

    Invalid SQL:
    INSERT INTO user
    (options, parentemail, salt, passworddate, password, email, username, usergroupid, languageid, usertitle, customtitle, showbirthday, birthday_search, birthday, timezoneoffset, ipaddress, displaygroupid, joindate, lastvisit, lastactivity, autosubscribe, showvbcode, threadedmode, reputationlevelid, reputation, pmpopup, maxposts, daysprune, startofweek)
    VALUES
    (3159, '', 'T<g', FROM_UNIXTIME(1167443414), 'e14fdf2365de9cfad79faec2f22ea80b', '[email protected]', 'resr', 2, 1, 'Junior Member', 0, 0, '', '', '0', '127.0.0.1', '', 1167443414, 1167443414, 1167443414, -1, 1, 0, 5, 10, 0, -1, 0, -1);

    MySQL Error : Incorrect date value: '' for column 'birthday_search' at row 1
    Error Number : 1292
    Date : Friday, December 29th 2006 @ 08:50:15 PM
    Script : http://localhost/kaizendigital/forum...p?do=addmember
    Referrer : http://localhost/kaizendigital/forum...p?do=addmember
    IP Address : 127.0.0.1
    Username : resr

    Classname : vB_Database
    I not done anything to any of the code, the only thing that i have done it create 3 links on my main site, 1 to login, 1 to logout and 1 to the register.php. why would i be getting this error?

  • #2
    I found out it i enabled the COPPA that the birthdate errors goes away but now i get this error:

    MySQL Error : Incorrect integer value: '' for column 'displaygroupid' at row 1

    Comment


    • #3
      First, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Version' in Diagnostics to make sure you have all the original files for your version:

      Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

      Next, disable all plugins.

      Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

      define('DISABLE_HOOKS', true);

      Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?

      If so, this may be due to your language pack. Try the English pack to see if you have the same problem.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        replacing files did not help but what i did what set the force_sql_mode to true becuase i am running 5.x on my local machine and that seems to fix everything.

        Comment


        • #5
          I had the same problem in my forum, and I found that the problem is that (in MySQL 5.0.2) strict sql mode is enabled, so no implicit default values are inserted.
          http://dev.mysql.com/doc/refman/5.0/...-defaults.html

          Just disabling strict mode solved the problem.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X