Announcement

Collapse
No announcement yet.

New signiture not showing in existing posts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New signiture not showing in existing posts

    I've got a strange problem with signitures.

    My board has only just been created and the initial posts that members made were without any signitures created. When they did create a signiture it will only show up in new posts and all of their posts created before they added a signiture to their profile do not have the signiture at all.

    Is this how it should work? Is there a way I can get the forum to add the signiture to the older posts created before they added a signiture to their profile?
    Retro Amiga gaming. Come visit us as http://www.classicamiga.com

  • #2
    You can go to the admincp/ > maintance > update counters > and rebuild post cache, this will also update existing posts.

    Comment


    • #3
      That sounded promising. I just tried rebuilding the post cache but it had no affect. I also tried emptying the signiture cache, but again it had no affect.

      I'm wondering if the following is true? If a member doesn't have a signiture setup and they make a post does vB miss out the part that adds a signiture to the post? And only once they have created a signiture new posts have the signiture part included to attach it to the bottom of posts?

      That seems the only logical reason for what is happening.
      Retro Amiga gaming. Come visit us as http://www.classicamiga.com

      Comment


      • #4
        I just tried adding a new signiture to my profile on this forum as a test to see if the same would happen, and as you can see it has. My new signiture is appearing on this new post, created since I added my signiture, but is not on my older posts above.

        Any ideas how it can get added to the existing posts?
        Retro Amiga gaming. Come visit us as http://www.classicamiga.com

        Comment


        • #5
          If you want signatures to show in older posts, run the following query:
          Code:
          UPDATE post
          SET showsignature = 1;
          Want to take your board beyond the standard vBulletin features?
          Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

          Comment


          • #6
            Great, that worked. Thank you.

            So as I suspected the forum does flag posts to show or not show the signiture on a post for post basis. Wouldn't it be better if the forum automatically changed this flag on all of a member's posts once that member has added a signiture to their profile? Other forums I have used such as Invision do this automatically.

            One question about this flag. Does vBulletin use this same flag to set the visibility of a signiture when a specific member or member group has signitures disabled? Or is this a different setting in the database?
            Retro Amiga gaming. Come visit us as http://www.classicamiga.com

            Comment


            • #7
              If you make a post, then you have the option to Show or not Show your signature (see check box below the message posting box). This is stored with the post in the showsignature column. If a user does not have a signature set, then this defaults to false.
              Want to take your board beyond the standard vBulletin features?
              Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

              Comment


              • #8
                Thanks. That explained what is happening perfectly. Makes sense now why this occured.
                Retro Amiga gaming. Come visit us as http://www.classicamiga.com

                Comment


                • #9
                  Yes, if the user posts with [ ] show signature , unchecked , it will not start displaying after you or they rebuild stats or change their signature.

                  The rebuild stats s only if there is already a sig added to the post

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X