Announcement

Collapse
No announcement yet.

Mysql of Mysqli in config.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mysql of Mysqli in config.php

    Hello there, I changed the config file as told in the manuel. Then I uploaded al the files in the upload dir to the server. Because the host works with php5 and latest version of Mysql i changed in config file mysql to mysqli, as told in the manuel. In step 3, get the messeage that mysqli can not be found or something. What is the problem?

    Editing config file again and edit mysqli to msql. After that uploading that file again? How can i restart the install procedure again?

    Thanks!

  • #2
    Have you renamed config.php.new to config.php? Also, have you entered all the information correctly?

    Comment


    • #3
      In that case you don't have to use mysqli, mysql will do just fine. Change it to mysql and try again.

      Comment


      • #4
        Originally posted by Alkah View Post
        Have you renamed config.php.new to config.php? Also, have you entered all the information correctly?
        Offcourse othetwise I think I could not succesfully made step 1 and 2 of the installation process. I will try what Floris says. Yesterday I tried that but It didn't work. I think FTP did not upload the file config succesfully.

        Comment


        • #5
          I just checked my file config.php on the server and it is set as:

          Code:
          ****** DATABASE TYPE ******
           // This is the type of the database server on which your vBulletin database will be located.
           // Valid options are mysql and mysqli, for slave support add _slave.  Try to use mysqli if you are using PHP 5 and MySQL 4.1+
          $config['Database']['dbtype'] = 'mysql';
          Still I receive ojn step 3 the message:

          Selected database type 'mysqli' was not detected within your compilation of PHP.

          Help

          Comment


          • #6
            I also have following settings in my config.php.

            Code:
             
             // ****** FORCE EMPTY SQL MODE ******
             // New versions of MySQL (4.1+) have introduced some behaviors that are
             // incompatible with vBulletin. Setting this value to "true" disables those
             // behaviors. You only need to modify this value if vBulletin recommends it.
            $config['Database']['force_sql_mode'] = false;

            Comment


            • #7
              I just deleted all files, donloaded the files again from vBulletin, made a new database on my host, edited the config.php and uploaded the files to host.

              Now on step 3 I get:

              Step 2) Connect to the database
              Attempting to attach to database
              Error description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) /home/bugriders.be/www/forum/includes/class_core.php on line 273
              The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

              Comment


              • #8
                Please see this page for the causes of this error:

                http://www.vbulletin.com/docs/html/cantconnect
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thx. Problem was 'localhost'. Must be name provided by host.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X