Announcement

Collapse
No announcement yet.

Error in whoisonline after reimport of database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in whoisonline after reimport of database

    Hi,

    I lost my database and had to import it from a backup file.
    After this I've had the odd problem or two with missing tables, but most seem to have solved themselves when I ran install.php.

    However, when users are looking at the index.php in forum root, who is online shows them as "Viewing Gallery Index".

    Must be a phrase error or something, but how do I fix this?

  • #2
    Update: When I uninstalled the gallery the phrases disappeared and now there is no text for "Viewing Index" or "Searching forums".
    Last edited by nepolia; Thu 30 Nov '06, 4:04am.

    Comment


    • #3
      Any ideas anyone?

      Comment


      • #4
        Sorry, I don't undertstand. Please re-explain and also provide the URL.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          The phrases for "Viewing Index" and "Searching Forum" has somehow been replaced by the phrases for the Gallery. This happened after the forum was imported from a backup file.

          Please see http://www.akasha.no/forum/online.php? and look at the actual links of those users who are searching the forum or looking at the index.

          Comment


          • #6
            It looks like your Gallery add-on did something to the master language and phrases.

            Try this. Upload the original vbulletin-language.xml file to the install directory. Then use the 'Download/Upload Languages' option under Languages & Phrases in the Admin CP to reupload the master language file.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Hi,

              No, that didn't work. Can I just add the phrase for "Viewing Index" into the Phrase Manager? I'm not sure what this is called though.
              Something might have happened with the language table in the database during the import, but I did run the Repair/optimize tables in Admin CP.

              Comment


              • #8
                Try running one of these queries:

                For MySQL 4.0.x use this query:

                DELETE
                FROM phrase
                USING phrase AS p1
                LEFT JOIN phrase AS p2 ON ( p1.varname = p2.varname
                AND p2.languageid = -1 )
                WHERE p1.languageid =0
                AND p2.languageid IS NOT NULL;


                Or for MySQL 4.1.x and higher, use this query:

                DELETE
                FROM phrase AS p1
                USING phrase AS p1
                LEFT JOIN phrase AS p2 ON ( p1.varname = p2.varname
                AND p2.languageid = -1 )
                WHERE p1.languageid =0
                AND p2.languageid IS NOT NULL;
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Then run this:

                  AdminCP -> Languages & Phrases -> Language Manager -> [Rebuild All Languages]
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks for your help, but it's still refusing to show the right phrases.

                    Btw. Should I have let it install a new language when I reuploaded the master language file? I chose to overwrite English US.

                    Comment


                    • #11
                      It would have orverwrote the master set if you did this right.

                      Up to now these steps have always worked. I suggest contacting the author of that Gallery you installed for help with fixing this. They did something insidious if those steps didn't fix this.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Ok. I'll try that.
                        The strange thing is that when I removed the gallery these phrases didn't appear at all in online.php, there was just empty space where the phrase should have been.

                        Can you just tell me what the Phrase Variable Name for these phrases are so that I can look for them?

                        Comment


                        • #13
                          Do a phrase search for those phrases.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Ok.

                            viewing_index Standard Phrase Viewing Index

                            and

                            adv_viewing_gallery_index Standard Phrase Viewing Gallery Index

                            As far as I can see it should be showing the right phrase.

                            Comment


                            • #15
                              Yes, which is exactly why I said they did something insidious. The above steps normally fix this but I'm afraid you will need to contact the Gallery author for help with this.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X