Announcement

Collapse
No announcement yet.

Upgrade issues (upgrade script)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade issues (upgrade script)

    I hope someone can help me.

    Everything has been uploaded for an upgrade to 3.6.4 from 3.5.4 and I go to run the script I get...

    Warning: Invalid argument supplied for foreach() in /includes/functions.php on line 1197

    Warning: Cannot modify header information - headers already sent by (output started at /home/gna/public_html/includes/class_core.php:3036) in /includes/functions.php on line 3440

    There is a box below that says


    Database error in vBulletin 3.5.4:

    Invalid SQL:

    SELECT eventid, userid, event.title, recurring, recuroption, dateline_from, dateline_to, event.calendarid, IF (dateline_to = 0, 1, 0) AS singleday, customfields,
    dateline_from AS dateline_from_user, dateline_to AS dateline_to_user, utc, dst
    FROM event AS event
    INNER JOIN calendar AS calendar USING (calendarid)
    WHERE ((dateline_to >= 1164254784 AND dateline_from < 1164600384) OR (dateline_to = 0 AND dateline_from >= 1164254784 AND dateline_from <= 1164600384 ))
    AND visible = 1
    AND calendar.options & 512
    ORDER BY dateline_from;

    MySQL Error : Unknown column 'dst' in 'field list'
    Error Number : 1054
    Date : Friday, November 24th 2006 @ 11:06:24 PM
    Script : http://www.-------------------
    Referrer :
    IP Address : ---------------
    Username : ---------------
    Classname : --------------

  • #2
    I think I figured this by going through C-panel

    Comment


    • #3
      Can you tell us what you figured out? I'm having the same issue you reported and would love to hear what your resolution was.


      EDIT: Well, I'm getting this message, same as you, but the page reports a database error with nothing useful outside of this:

      Warning: Invalid argument supplied for foreach() in /includes/functions.php on line 1197
      Last edited by Gnomercy; Mon 27 Nov '06, 5:10pm.

      Comment


      • #4
        I imagine bumping this thread this is probably bad form, but I'm still looking for a solution to this problem and this was the only thread my searching turned up for this error message. Can anyone help me determine what might be causing this?

        Comment


        • #5
          I kicked my upgrade script off by going to my file manager in the C-panel tool on my server.

          Don't ask me why I tried it? Just desperation I suppose? When I clicked on the URL from there it launched the script and I was able to upgrade. I did nothing else different to make this work before I tried that.

          It has been my experience with V-bulletin and VBseo that the instructions never work the way they say. Maybe it is the way my server is setup or how my files CHMOD'ed, I dunno?

          Comment


          • #6
            Most vBulletin upgrades I've done over the years have gone flawlessly... never run into anything like this before.

            Thanks for sharing what worked for you. I'll get over to this asap and give it a shot.

            Comment


            • #7
              Well you gotta love this. For testing purposes, I put a copy of the site on another server to test the upgrade process with... no problems at all. Re-uploaded the new version to try to replicate the previous problem and was unable to. No errors on the original upload, but apparently there was some corruption in there someplace.

              Thanks for getting back to me with what you did.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X