Announcement

Collapse
No announcement yet.

Cannot login if "Remember me" not check

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot login if "Remember me" not check

    I'm using vBulletin 3.6.3. I and my users cannot login to forum unless the "Remember me" box is checked, I know that kind of problem is something to do with the cookies settings, but all my cookies settings are set to default, I change nothing.
    By the way, if in the case users must check "Remember me" to login, will the cookies be expried after a specified amount of time, or they just remain login forever?

  • #2
    First check the Cookie Timeout in your vBulletin Options. Make sure it is not set too low (default is 900 seconds).

    When you use remember me, then the cookie will never timeout, and the user will be automatically logged in the next time they will visit your board.
    Want to take your board beyond the standard vBulletin features?
    Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

    Comment


    • #3
      As I said, I leave cookies setting the default level, timeout is 900, path is "/" and so on...
      Does this problem have any relation to the cookie settings and security settings on the client machine? (Such as firewall that blocks cookes)

      Comment


      • #4
        Yes blocking the cookie on the client machine could influence the forum behaviour.

        Could you test creating a new style with no parent set, and see if your problems are fixed when using this new style?
        Want to take your board beyond the standard vBulletin features?
        Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

        Comment


        • #5
          Remember Me uses cookies. The fact that checking Remember Me works better tells me that's not it.

          Are any of these users on AOL? AOL rotates IP addresses constantly, which screws up sessions (what vB uses if you don't click Remember Me).

          Comment


          • #6
            I tried to use the default skin and a test account (normal user) to login, as usual, if I didn't check the "Remember me" then box on the top-right of the screen still showed the username and password box, instead of the welcome message, when I changed the forum or topic, then it showed the welcome message (as if I was loged in) and if I continue to change forum or topic, it showed the username and password box again... that's funny

            If you have time, please have a look at a video clip that I record from the screen here: (I'm using a language with UTF-8 encoding, I switch to English before recording screen, so that some funny text appear, it's not important anyway.)

            http://forum91.heavenofsix.com/probl.../Untitled.html

            http://forum91.heavenofsix.com is also the link to my forum, you can test it yourself

            Comment


            • #7
              I found out that some other people have the same problem like the topic "Cokies issue..." or "can't login without remember me..."
              Did anyone figure out what causes this problem?

              Comment


              • #8
                I am also experiencing the same problem...??

                I have two forums on two separate servers. Settings on both forums are exactly the same. Everything works the same, but the login.

                I can login on my first forum with no problems. Remember me checked our unchecked.

                I cannot login on my second forum if remember me is not checked. If it is checked, then I can login.

                Any ideas?

                Comment


                • #9
                  Same problem

                  Bump - having the same problem - don't understand some of the posts here about using differnet skin, using default skin . . . client gets message, thanks for loggin in and returns back to the same login prompt

                  Comment


                  • #10
                    Please start your own thread with all the relevant details. Thank you.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by microman View Post
                      Bump - having the same problem - don't understand some of the posts here about using differnet skin, using default skin . . . client gets message, thanks for loggin in and returns back to the same login prompt

                      same problem facing this days

                      any solution?

                      Comment


                      • #12
                        Please start your own thread with all the relevant details. Thank you.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X