Announcement

Collapse
No announcement yet.

Firefox Stops Rendering

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BruceWest
    replied
    I'm using 2.0 as well.

    Leave a comment:


  • LSIntegra94
    replied
    This is an interesting find. I checked a virgin install at work but both settings are set to true. The cache is set at 50mb. This is on v2.0

    Leave a comment:


  • BruceWest
    replied
    This was one nasty little bug. It was caused by wrongly configured parameters within Firefox.

    Now, any normal Firefox user would believe that by going to Tools > Options > Advanced > Network and entering a higher MB value for the cache would work. Not so. Even after setting this value to 1 GB my problems persisted. That is the only cache option available to the average user.

    What is there left to do, then? You must next visit the Firefox master configuration table. Here's how I fixed my problem.
    • In a new tab, enter the following address in the address bar
      about:config
    • On the following page, scroll to the b section (the list is alphabetical).
    • Find browser.cache.memory.enable. On MY installation, that option was set to FALSE. =\ Sounds like we discovered the culprit. Double click this row value to change from FALSE to TRUE.
    • Find browser.cache.disk.enable. Again, for me this value was set to FALSE. This preference is not as critical as the previous one, but for convenience it can be set to TRUE.
    Indeed, upon each and every page load, my browser was sending out a GET as if it had short-term memory loss. Every icon, .css file, image, EVERYTHING was loaded EVERY time I refreshed my browser. If there were 10,000 instances of the SAME icon on the page, then the browser made 10,000 INDIVIDUAL requests. No WONDER my server's anti-DDOS system kicked in. =P

    I hope this can serve as a guide to those with lesser experience in Firefox. It took longer than it should have for me too realize what the problem was. Cheers to your success!

    Leave a comment:


  • Jake Bunce
    replied
    It sounds like you have narrowed down the problem to your FF browser. I have no idea what could be causing that. You mentioned a flood of requests per page. You might check your browser's cache settings.

    Leave a comment:


  • BruceWest
    started a topic Firefox Stops Rendering

    Firefox Stops Rendering

    I understand this is probably a user-specific (not site-specific) issue, so if it'd be better suited to the Chit Chat forum, please accept my apologies.

    It's strange. I've reinstalled Firefox on my machine 3 times (completely wiping old installations first). Without fail, I will continue to see partially loaded pages (missing images where alternate text is used) and Forbidden sever errors while visiting my vBulletin message board. IE 6 and 7 have no problems rendering the page.

    Something about the server hates my specific Firefox installation. My laptop's installation works just fine, and I haven't heard any negative reports from my members.

    Example: I've noticed that in Firefox, instead of loading /images/statusicon/forum_new.gif once, it loads it over and over and over for each table cell. I have a feeling that the mass requests coming from my Firefox browser are invoking mod_evasive's anti-DDoS techniques (as it should, thus the temporary and sporadic Forbidden errors.) I don't think Firefox should be loading each and every image for every instance on the page as it has been doing. That's over 1,000 individual HTTP GETs per page on some of the larger pages.

    Any ideas?
    Last edited by BruceWest; Fri 10th Nov '06, 8:57pm.

Related Topics

Collapse

Working...
X