Announcement

Collapse
No announcement yet.

Trouble with long post

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with long post

    Hello,


    I am trying to submit a post that is quite long (about 20k). From VB's control panel I removed the limit to 10.000 characters,but now I get the error:

    "The connection was reset"

    How can I fix this ?

    This is a plain Vanilla VB 3.6.2 installation without any hack on it.


    Note:
    I also checked the limit for POST method in my php.ini file - and there I have 16MB which is much more than necessary. Also, please note that I get the above error instantly.


    Please tell me how to fix this.



    Regards,
    Razvan

  • #2
    Check the 'max_allowed_packet' setting in MySQL as well as the max_execution_time and max_input_time variables in php.ini
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      Check the 'max_allowed_packet' setting in MySQL as well as the max_execution_time and max_input_time variables in php.ini
      I get this error in less than half a second. I don't think that any time out occurs.

      Where is the configuration file for MySql ? I search the whole directory tree for a file that contains "max_allowed_packet" and I didn't found anything.


      I have MySQL 5.0.24a and I don't find the damn ini file.



      Regards,
      Razvan
      Last edited by mihai11; Fri 10th Nov '06, 5:29am.

      Comment


      • #4
        MySQL doesn't list all the variables in the configuration file, these can simply be added.

        The file is usually named my.cnf
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Yes, I found the file. Strange, the settings "max_allowed_packet" is there but the search routine did not found it. This would have never happen on Linux.

          Anyway, its value is 1 MB:

          max_allowed_packet = 1M

          Hmmm... this setting in found in 2 places in this file. The second time it appears it has the value 16M.

          I attached the whole file for you to see - it is small, only 3kb. Please take a look and tell me if you see anything wrong.




          Regards,
          Razvan
          Attached Files

          Comment


          • #6
            Hey ! Nobody can help me with this issue ?!

            Comment


            • #7
              I am having a similar problem. I can post a few words at a time with no problem... when I try to reply in a thread, or even start a new thread with a paragraph that is too long, I'm getting this error:

              Not Acceptable

              An appropriate representation of the requested resource /forum/newthread.php could not be found on this server.



              or with the reply, this error:

              Not Acceptable

              An appropriate representation of the requested resource /forum/newreply.php could not be found on this server.

              Is this a problem that is addressed in the 3.6.3 upgrade?

              Comment


              • #8
                LilyLesPaul,

                Yours is a different issue. Please start your own thread.

                mihai11,

                Delete the "max_allowed_packet" 1M line and keep the 16M line. Also please post the contents of your file if you need help rather than a zip file.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Okay

                  Comment


                  • #10
                    Delete the "max_allowed_packet" 1M line and keep the 16M line. Also please post the contents of your file if you need help rather than a zip file.
                    I zipped the file because the system would not accept it as an attachment otherwise.

                    The content of "my.cnf" file follows. I commented the line that you said that must be deleted, but it did not changed the situation. I am still getting the same error.

                    Code:
                    # Example MySQL config file for small systems.
                    #
                    # This is for a system with little memory (<= 64M) where MySQL is only used
                    # from time to time and it's important that the mysqld daemon
                    # doesn't use much resources.
                    #
                    # You can copy this file to
                    # D:/WebDev/xampp/mysql/bin/my.cnf to set global options,
                    # mysql-data-dir/my.cnf to set server-specific options (in this
                    # installation this directory is D:/WebDev/xampp/mysql/data) or
                    # ~/.my.cnf to set user-specific options.
                    #
                    # In this file, you can use all long options that a program supports.
                    # If you want to know which options a program supports, run the program
                    # with the "--help" option.
                    
                    # The following options will be passed to all MySQL clients
                    [client] 
                    # password       = your_password 
                    port            = 3306 
                    socket          = mysql 
                    
                    # Here follows entries for some specific programs 
                    
                    # The MySQL server 
                    [mysqld] 
                    basedir="D:/WebDev/xampp/mysql" 
                    tmpdir="D:/WebDev/xampp/tmp" 
                    datadir="D:/WebDev/xampp/mysql/data" 
                    
                    port            = 3306 
                    socket          = mysql 
                    
                    old-passwords 
                    character-set-server = latin1
                    collation-server = latin1_general_ci
                    
                    skip-locking
                    key_buffer = 16K
                    
                    # I commented the line below
                    #max_allowed_packet = 1M
                    #
                    
                    table_cache = 4
                    sort_buffer_size = 64K
                    read_buffer_size = 256K
                    read_rnd_buffer_size = 256K
                    net_buffer_length = 2K
                    thread_stack = 64K
                    
                    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
                    # if all processes that need to connect to mysqld run on the same host.
                    # All interaction with mysqld must be made via Unix sockets or named pipes.
                    # Note that using this option without enabling named pipes on Windows
                    # (using the "enable-named-pipe" option) will render mysqld useless!
                    # 
                    #skip-networking
                    server-id    = 1
                    
                    # Uncomment the following if you want to log updates
                    #log-bin=D:/WebDev/xampp/mysql/data/mysql-bin
                    
                    # Uncomment the following if you are NOT using BDB tables
                    skip-bdb
                    
                    skip-innodb 
                    # Uncomment the following if you are using InnoDB tables 
                    #innodb_data_home_dir = D:/WebDev/xampp/mysql/data/
                    #innodb_data_file_path = ibdata1:10M:autoextend 
                    #innodb_log_group_home_dir = D:/WebDev/xampp/mysql/data/
                    #innodb_log_arch_dir = D:/WebDev/xampp/mysql/data/
                    # You can set .._buffer_pool_size up to 50 - 80 % 
                    # of RAM but beware of setting memory usage too high 
                    #set-variable = innodb_buffer_pool_size=16M 
                    #set-variable = innodb_additional_mem_pool_size=2M 
                    # Set .._log_file_size to 25 % of buffer pool size 
                    #set-variable = innodb_log_file_size=5M 
                    #set-variable = innodb_log_buffer_size=8M 
                    #innodb_flush_log_at_trx_commit=1 
                    #set-variable = innodb_lock_wait_timeout=50 
                    
                    [mysqldump] 
                    quick 
                    max_allowed_packet=16M 
                    
                    [mysql] 
                    no-auto-rehash 
                    # Remove the next comment character if you are not familiar with SQL 
                    #safe-updates 
                    
                    [isamchk] 
                    key_buffer = 8M
                    sort_buffer_size = 8M
                    
                    [myisamchk] 
                    key_buffer = 8M
                    sort_buffer_size = 8M
                    
                    [mysqlhotcopy] 
                    interactive-timeout 
                    
                    [WinMySQLadmin] 
                    Server="D:/WebDev/xampp/mysql/bin/mysqld.exe"
                    #user=root
                    #password=
                    Please take a look.


                    Regards,
                    Razvan

                    Comment


                    • #11
                      What is the exact error you are getting?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        This is what I am getting in Firefox 2.0:


                        Code:
                        The connection was reset
                        
                        The connection to the server was reset while the page was loading.
                        
                            *   The site could be temporarily unavailable or too busy. Try again in a few
                                  moments.
                        
                            *   If you are unable to load any pages, check your computer's network
                                  connection.
                        
                            *   If your computer or network is protected by a firewall or proxy, make sure
                                  that Firefox is permitted to access the Web.
                        In Internet Explorer 6.0 the error is generic:

                        Code:
                        The page cannot be displayed
                        
                          The page you are looking for is  currently unavailable. The Web site might be experiencing technical  difficulties, or you may need to adjust your browser settings.
                        I am getting this error *instantly* - obviously there are no time-outs. Something is wrong and the error appears immediately.


                        The error is the same if I try "Preview post" or "Submit reply". If I make the post smaller then there are no issues.

                        The post that I try to enter has around 10 kb.




                        Regards,
                        Razvan

                        Comment


                        • #13
                          If you have installed any Plugins or Products, first disable these to see if you still have this problem.

                          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                          define('DISABLE_HOOKS', true);


                          If you still have this problem with plugins disabled, check the includes/xml directory and make sure only the original vB files are in there and none from any add-ons. Then if you still have a problem and have not installed any hacks (which includes portals), fill out a support ticket at:

                          http://members.vbulletin.com/members...ontactform.php

                          Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            I just deleted *all* the forum files then I reinstalled VB. Upon reinstalling I chose the option to empty the database. With this completely new VB installation I am still getting the same error while entering a big post (like I said, the post has around 10k).


                            This VB installation is on my local PC. I am doing tests and some development before putting this online therefore this forum is not available from outside my home network.

                            Can you send me a valid "my.cnf" configuration file ? One that you use in production. I will research the differences between your file and mine.


                            Note:
                            Have you got time to look at the configuration file that I sent to you in a previous post ? I have the feeling that this is a very simple error. It is possible that you would spot the problem instantly if you would check the file.



                            Regards,
                            Razvan

                            Comment


                            • #15
                              In order to get further help, please follow the instructions in post #13.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              Loading...
                              Working...
                              X