Announcement

Collapse
No announcement yet.

server with UTC time format, and forum showing 1 HOUR less for GMT time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • server with UTC time format, and forum showing 1 HOUR less for GMT time

    I'm having a problem with http://foro.acuarios.es, my server time is set as UTC time, and my forum is showing 1 HOUR less for GMT time.

    So it's not doing the summer time +1 correction over UTC time.

    How can I trace where the problem comes from, and
    How can I do some fix for that?, Where does vbulletin take time info from?

  • #2
    vBulletin gets its time from the server. You need to set the timezone and DST settings in the Admin CP to match the timezone of the server your forums are running on. Then each user needs to set their local timezones/DST in the User CP. If you do this correctly and the server time is correct, then the correct times will show.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post
      You need to set the timezone and DST settings in the Admin CP to match the timezone of the server your forums are running on
      I've been searching and searching for that option, but what I found it was the "default timezone for users" and DST config.

      Where is it located?

      Thank you very much.

      Comment


      • #4
        Admin CP -> vBulletin Options -> Date and Time Options
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          This is what I find there, but that's not the timezone for server, that's the default timezone for guest and new users.

          Default Time Zone Offset

          This is the default time zone for guests and new members on your forum. For example, if most of your visitors are from California, then you should set this to Pacific Time.

          Note that vB3 gets your server's time zone from PHP. If you need to change your server's time zone, then you need to change your server configuration. You should contact your host for help with this.
          Any hint of where does vbulletin gets time from server? I've been searching for calls to php "date" function across vbulletin source code, but didn't find any reference.

          Comment


          • #6
            Not sure why you need that. Please explain what exactly you are doing. It does take it's time form the server (where else would it get this?) and if you have the correct settings as I specified, it will show the correct time.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I suppose problem is that the server is giving time in UTC format,
              for example, now:
              Oct. 22, 20:44:17 UTC

              UTC time is like GMT+0 without summer time correction (+1h) in summer.

              Then, for a GMT+1 user, with DST correction enabled, it should show like UTC + 1h (GMT+1 ) + 1h (summer time correction) what would be:
              Oct. 22, 22:44:17 GMT+1


              But, what it's showing its:


              Oct. 22, 21:44:17 GMT+1 (which is wrong)


              I think, that for some reason it isn't aplying the DST correction. (that behaviour will disapear when DST is not needed ... that's soon, don't know exactly which day)



              The setup in my server it is, but don't see any more related options in the "Date and Time Options" :
              Default Time Zone Offset
              Time zone offset for guests and new users. Do not take DST into consideration, rather use the next option to enable/disable DST.
              (GMT +1:00 hour) Brussels, Copenhagen, Madrid, Paris


              Enable Daylight Savings

              If Daylight Savings Time is currently in effect for the above time zone, enable this option so that guests will see the correct times on posts and events. This has no effect on registered users as they control their DST options in the User CP.
              Yes No

              Comment


              • #8
                Sorry but I have a difficult time following that. If you are running the default vB code and you have the correct settings, then the correct time will show.

                And since you posted in the 3.6 forum, I aassume you are running vB 3.6.x. In that case the Date and Time options are right here:

                Admin CP -> vBulletin Options -> Date and Time Options
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  What I'm trying to say is that I have that correctly set'd up, but It's not working correctly, Can you try to find somebody who knows how does that part of vbulletin works to try to fix it (i think it's some kind of bug...).

                  Comment


                  • #10
                    There is no bug and it does work when the correct settings are used.

                    Have you tried adjustuing the Default Time Zone Offset setting until you get the right time?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I'm right now changing this, and trying with my user "ajo" logged on,

                      what I get is always the same time... this setting help says: this is only the default timezone for new and guest users (not the server timezone).

                      Comment


                      • #12
                        Anyway, I think the problem somehow fixed this way:


                        going to the User CP:

                        the first time configuration was like this: (and time was showing wrong)

                        Timezone : GMT + 1
                        DST correction : Automatic


                        then I changed to (time started to show correctly)

                        Timezone: GMT + 1
                        DST correction: always


                        and then, changed it back to: (time was still showing correctly but setup was the same like at start)

                        Timezone: GMT + 1
                        DST correction: Automatic



                        I'll try to clean cookies,logout, and see if it's still showing correctly after login. Also I'll try to create a new user to test the timezone.

                        Comment


                        • #13
                          I just upgraded and have this exact same problem. For any disbelievers that this is infact a VB error take a gander at the bottom of this very page.
                          it shows All times are GMT -4. The time now is 12:33am. The current time is right for MY timezone GMT -5 not GMT -4. Also in my navbar the time is 3 hours behind. I checked the server time and all the settings. Everything is set right.

                          So unless VBulletin.com has the same hacks as me and ajo... me thinks there is a prob with Vbulletin itself.

                          Comment


                          • #14
                            I'm not going to argue with you although I know the problem is not with vB.

                            If you can duplicate this problem on a vB with no hacks, plugins or add-ons, then please report this in the 3.6 Bug Tracker here:

                            http://www.vbulletin.com/forum/bugs36.php
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Did you look at the bottom of this page? Here on VBulletin.com? I'm not trying to argue but if you guys have the exact same prob as me it makes me wonder if it could be a hack.

                              I will submit a bug report. I know that hacks are the main cause for issues with Vbulletin and you guys do an awesome job but you have to admit the evidence is a little overwhelming.
                              I'll paste this from the bottom of this very page once more.
                              All times are GMT -4. The time now is 12:48am.
                              Current time for GMT -4 is 1:48am

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X