Announcement

Collapse
No announcement yet.

Cron Jobs not running

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cron Jobs not running

    For some reason none of my scheduled tasks are running. I tried to run the manual infractions one just now as none of the infractions are clearing and I got this error:

    Infractions Cleanup

    Warning: implode(): Bad arguments. in \includes\functions_infractions.php on line 149

    Done

    I am wondering as this is one of the first tasks if it is hitting this error and refusing to go any further. Help would be appreciated.

    Thanks

  • #2
    Scheduled Tasks are triggered by code in the footer template, so if you have modified this template or added code to other templates it may interfere with the running of the tasks. Also if there is no activity on your forums, the task won't run.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      It is a very active forum so I will look into the footer template. I did update the code within the footer template to display the forum status icons differently - could this be the problem? If you want me to cut and paste the code then just let me know.

      Thanks for the help.

      Comment


      • #4
        I have seen different code interfere with the $cronimage function. You'll need to remove your added codes one at a time to see which one is causing this.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Ok, I will run a complete revert of the footer template. I take it if I then ran the manual scan for the Infractions cleanup it shouldnt report the error anymore if that was the problem - we will soon see.

          Comment


          • #6
            Hmm, no its not the footer. Just checked and the footer template has never been touched, I must be getting it confused with the forum display template. So I am running a "clean" footer template here.

            Comment


            • #7
              Then some other change you made is interfering with this function.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Hmm, after installing I reverted all templates. So very few changes are in place. Any idea where I should be looking?

                Comment


                • #9
                  Scheduled tasks do work with the original vB code. If all of your templates are original and unmodified, then the next step is to reupload all the original vB files and disable your plugins.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Baker011,

                    please keep us updated and let us know what you ultimately do to fix the problem. We are having the same problem on a 3.5.x installation right now.


                    Did you change servers or anything like that recently?

                    Comment

                    Loading...
                    Working...
                    X