Announcement

Collapse
No announcement yet.

Big problem after database import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Marco van Herwaarden
    replied
    Please open a support ticket. Make sure to include details to AdminCP (english please), FTP/SSH and phpMyAdmin if available.

    Leave a comment:


  • Kurisu
    replied
    Originally posted by Marco van Herwaarden View Post
    For both the backup-database and the new database:
    - What MySQL version?
    - What is the default collation for the database?
    MySQL 5.0.24

    MySQL charset: UTF-8 Unicode
    MySQL connection collation:: utf8_unicode_ci
    The databases use utf8_general_ci

    Leave a comment:


  • Marco van Herwaarden
    replied
    For both the backup-database and the new database:
    - What MySQL version?
    - What is the default collation for the database?

    Leave a comment:


  • Steve Machol
    replied
    Unfortunately I have no idea how to fix this but I'll ask the other staff members to take a look at this thread.

    Leave a comment:


  • Kurisu
    started a topic Big problem after database import

    Big problem after database import

    I've spent days to fix this problem but now I give up. I'm in desperate need for help.

    I did a backup of my database via SSH and imorted it.
    Normally that should work fine. But in my case it doesn't.
    I get this error:

    HTML Code:
    Warning: array_keys() [function.array-keys]: The first argument should be an array in /includes/functions.php (line 3503)
    
    Warning: Invalid argument supplied for foreach() in /includes/functions.php (line 3503)
    I am also told that I am banned for unknown reaseon and that the ban will never be lifted.

    Both errors can be fixed using tools.php.

    But the real problem is this:
    All umlauts are replaced by strange chars (like ü instead of ü) and there are absolutely no phrases - as if the phrase table would be empty (which is not the case).

    If I import the language file using tools.php the phrases are being displayed again.
    But if I post something that contains chars like ö, ä, ß everything is cut of.
    testäöü -> test


    Apache v2.2.2
    PHP 5.1.4
    MySQL 5.0.24
    Encoding utf8
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X