Announcement

Collapse
No announcement yet.

New install error (not database!)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New install error (not database!)

    I was trying to install the new 3.6 to test it at my server, and the installation went fine. I delete install/install.php and click the link to go to the admincp as usual and I get this:

    Code:
    Warning: Invalid argument supplied for foreach() in /includes/class_core.php on line 2812
    
    
    
     
    Unable to add cookies, header already sent.
    File: /home3/tvf/public_html/forum/includes/class_core.php
    Line: 3012
    I can't access anything. The install is fresh, no hacks/plugins. This is the only board on the domain. PHP version 4.4.3 and MySQL version 4.1.21-standard.

    I've reuploaded all the files again, in ASCII, reinstalled, etc. Nothing fixes this. Whats wrong? Also, I tried clearing cookies.

    Edit: mysqi doesnt work :P force_sql_mode set to true doesnt work.
    Last edited by Mijae; Wed 23rd Aug '06, 9:21pm.

  • #2
    There isn't a mysqi mode only mysqli, Reupload the default vBulletin files, again if you have to delete them first. Files are badly uploaded.

    Comment


    • #3
      By mysqi I ment mysqli.

      I deleted all the files and uploaded again and no luck. What is causing this? I've reuploaded reveral times and nothing is fixing it.

      Comment


      • #4
        PHP Code:
                    if (!defined('SKIP_USERINFO'))
                    {
                        
        // get default language
                        
        $phraseinfo $this->registry->db->query_first_slave("
                            SELECT languageid" 
        fetch_language_fields_sql(0) . "
                            FROM " 
        TABLE_PREFIX "language
                            WHERE languageid = " 
        . (!empty($this->vars['languageid']) ? $this->vars['languageid'] : intval($this->registry->options['languageid'])) . "
                        "
        );
                        foreach(
        $phraseinfo AS $_arrykey => $_arryval)
                        {
                            
        $this->userinfo["$_arrykey"] = $_arryval;
                        }
                        unset(
        $phraseinfo);
                    }

                    return 
        $this->userinfo;
                }
            } 
        Is the area of code is erroring out on...

        Try wiping the database and reinstalling again.

        Comment


        • #5
          I am getting the same error zachery.

          I have reuploaded everything like suggested and i still get the same exact error as the originator of this post.

          Warning: Invalid argument supplied for foreach() in /includes/class_core.php on line 2812


          Unable to add cookies, header already sent.
          File: /home3/hotwheel/public_html/forums/includes/class_core.php
          Line: 3012

          Comment


          • #6
            Ok, I reuploaded everything yet again and then reinstalled. This time it worked.

            Weird :P

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X