Announcement

Collapse
No announcement yet.

Attachment Uploading - Not so good

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment Uploading - Not so good

    Hi Guys,

    I just have some questions and comments about the uploading system that VBulletin has. Imo its terrible, it may just be my vb board or server but its as good as usless to me at the moment and id like to see if there is anything i can do to improve the situation.

    First off, i upload the file the first time and i get this message:

    name.zip:
    Upload of file failed.

    This also happens on the seconds, third etc etc. On the 6th time it finally works.

    Why is it doing this? My forum is extreamly download based and i get nothing but problems from this upload system. Not to mention to the time to upload. It was a 2mb file and im waiting over 4mins for it to upload when other upload systems can upload it first time, everytime in around 1-2mins.

    What gives?

  • #2
    If it suddently works the 6th time then it's most likely a server issue, unless you did something differently.
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      It only suddenly worked when i tried to use something different to upload, it was a small jpg images that uploaded sucessfully.

      Im getting database errors which is causing that IE window to crash, all im trying to do is upload a 2mb zip. Its a totally fresh install.

      Comment


      • #4
        In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini

        upload_max_filesize = xM

        ..and my.cnf (or my.ini for Windows systems)

        set-variable=max_allowed_packet=xM

        Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

        Note You may also need to increase the max_execution_time and max_input_time variables in php.ini.
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Here is what i keep getting ( see attachment), other than the upload failed message. I uploaded a zip that was only several KB big and that worked so it must be the size of the file or the amount of time it is taking to upload it.

          I would scroll down and show you the whole message but the window has crashed...



          oops you posted while i was posting, i didnt read your reply when i posted this.



          Ill try to do the above edits and get back to you to see how i get on. Thanks for the reply and info
          Attached Files

          Comment


          • #6
            I also have a question. If i am getting the message:

            xxxxxxxxxx.zip:
            Upload of file failed.

            and not a database error, could that still be caused by settings in the php.ini file or is that a problem with VB?

            Comment


            • #7
              It could be anything, including a server issue. Run the Upload Diagnostics and report back the results:

              Admin CP ->Maintenance -> Diagnostics -> Upload
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Well, i used it with the same file i was having problems with before (zip, +3mb) and it gave me this reply:

                No file uploaded and no local file found. The test cannot continue.
                Does that shed any light?

                Comment


                • #9
                  Try a smaller file. Your server may not be able to handle a 3Mb file.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    The silence from the forum gods is deafening...

                    I too attempted to try to upload files to the database an now I have some questions about this rather user-unfriendly aka frustrating procedure:

                    1. Isn't there a more elegant way to determine that something is missing or too big BEFORE an upload actually commences?

                    2. Must the entire browser crash everytime the mysql service reports an error? I never get a chance to see WHAT it is trying to tell me because the entire browser dies. This occurs in Microsoft Exploiter/Netcaptor but also in Firefox. Only Opera is able to handle the error and display the actual message that is returned. Which brings us to:

                    3. why do the upload limits not work? On the admin front page I am told that the max upload = 2.00 Mb
                    considering that there is an offset in base 2 calculations, 2.00 MB = 2,097,152 bytes and that is what I set the limit to.
                    But when I upload a file the size of a floppy disk or 1.37 MB (1,439,110 bytes) the database pukes and reports:

                    "Invalid SQL:
                    INSERT INTO attachment
                    (dateline, thumbnail_dateline, visible, userid, extension, filename, posthash, filehash, filesize, filedata)"
                    "Got a packet bigger than 'max_allowed_packet'"

                    What's up with that? How is 1.37 MB bigger than 2.00 Mb? Someone having some trouble with their elemetary Algebra perhaps?


                    Other users apparently experience the same problem (http://www.vbulletin.com/forum/showp...6&postcount=3), and
                    http://www.vbulletin.com/forum/showp...11&postcount=5

                    I would venture to guess that the database error reporting template is badly flawed. It should not behave like that at all. Can we address this urgently please?
                    Last edited by Polinco; Mon 4th Sep '06, 12:10am.

                    Comment


                    • #11
                      Sounds like a server side issue to me - Got a packet bigger than 'max_allowed_packet'

                      That will need to be adjusted - check here...
                      http://dev.mysql.com/doc/refman/5.0/...too-large.html
                      Lats...

                      Comment


                      • #12
                        I knew that wasn't going to help. I set my max upload to be 8 Mb in the php.ini file and 'max_allowed_packet' also to 8 Mb in the my.cnf.

                        This should NOT EVEN be an issue.

                        Any other ideas?

                        Comment


                        • #13
                          Check all the settings mentioned in post #4.
                          You might also have to restart MySQL / Apache for them to take effect.
                          Best Regards
                          Colin Frei

                          Please don't contact me per PM.

                          Comment


                          • #14
                            Colin, That is the first thing I did, I changed the settings as per your post to 8 Mb. There were 3 php.ini files on my server, one in /etc/ one in /usr/ and one in /home/. I also changed the my.cnf file.

                            Then I restarted both the mysql server and the httpd server from Cpanel.

                            I still get the max limit of 2 Mb warning when I attempt to upload a 4 Mb file.

                            Now what?

                            Comment

                            Loading...
                            Working...
                            X