Announcement

Collapse
No announcement yet.

newreply.php error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • newreply.php error

    After a user submits their reply, they are redirect to a blank page. The reply gets posted, but the user does not get redirected back to the forums.

  • #2
    To troubleshoot this, remove any hacks and disable your plugins, then see if you still have this problem.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file.

    Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      All suggestions have been tried. The site was workign before I switched from Apache 2.2 to lighttpd. The switch had to be made because vbulletin 3.6 was putting to much load on apache.

      Comment


      • #4
        Then it must be due to the server change. Try this:

        http://www.vbulletin.com/forum/showthread.php?t=167121

        If that doesn't work then I have no idea how to help with this. You might wanrt to try the server configuration forum.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Toad did you try the htaccess file fix thing yet?
          Joshua Combs
          Webmaster/Founder Quad4forums.com | ECOTECforum.com
          Streamline Web Solutions
          [email protected]

          Comment


          • #6
            I tried, nothing changed. I think the solution is only works for apache. I think I'm going to move the server to a hybrid setup of lighttpd and apache.

            Comment


            • #7
              I switched to apache 1.3x and the error went away, using proxy to serve images with lighttpd. Lighttpd was preventing newreply.php to refresh the page. I'll have to take a closer look at all the cgi options for php.

              I think line causing problems is
              eval('print_output("' . fetch_template('newreply') . '");');

              Comment


              • #8
                I just upgraded from 3.5.4

                I have the same problem as described above.

                when a user replies to a thread, the post is submitted, but the user gets a blank page.

                I have not changed any templates. I've changed the URL of the Logo to mine.

                I'm running:

                PHP 5.0.4 as an Apache Module
                Apache 2.x
                vBulletin 3.6.0

                Does anyone have any other ideas?

                Comment


                • #9
                  Its like the function stops right after the post is submitted. .... asynchronous inserts malfunctioning, ... need to move to slower apache 1.3x (slow file server, fast php server) ...... or maybe just need to get that 8-way Opteron Sun V40z server.

                  Comment


                  • #10
                    I'm on a Dual Opteron with 8GB RAM.. I don't think I'm running into any load problems

                    Load averages are less than .3

                    Comment


                    • #11
                      For debugging purposes. I am running FreeBSD 4.9 Apache 1.3 php 4.4.3
                      Active users: 1000~1600

                      Comment


                      • #12
                        I fixed mine....

                        I was getting a memory error... so I upped PHP's memory allocation.

                        I added this to my includes/config.php

                        ini_set( 'memory_limit', '20M' );

                        The error I was receiving before was this:

                        PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 661648 bytes)

                        Comment


                        • #13
                          No memory error here. I set the memory limit to 26 megs, then 32 megs.

                          Comment


                          • #14
                            Does your apache error log reveal anything?

                            Comment


                            • #15
                              For me, Apache 1.3x works well (but slow in comparison) Apache 2.2x works better, but threads tend to crash under highload. Lighttpd work very well, but caused a error in newreply.php (full error reporting on, reported no errors)

                              According to the php manual, "eval" returns False if their is a parse error in the code. In case of fatal error in "eval", the whole script exists. I don't think this would turn a error code if the function terminates or returns false.

                              Comment

                              Loading...
                              Working...
                              X