Announcement

Collapse
No announcement yet.

Display multiple image attachments?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Display multiple image attachments?

    I searched the archives here and there was a control for this in the previous versions of vB but I can't find it in 3.6.

    When users post one image, it appears in the thread as a picture.

    When users post more than one image, the pictures appear as links, not images. I would like all the attachments to appear as images.

    I have turned off thumbnails. I'm not interested in those. I have limited the proportions of images that users can submit, so now I just want them all to display.

    I know there is a way to do it, just can't find it.

    Thanks!

    Jonathan

  • #2
    Admin CP -> vBulletin Options -> Message Attachment Options -> View Attached Images Inline -> Yes
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hey Steve,
      Thanks. However I already did that several days ago and I rechecked it when I just posted some images today and it's still doing it. Do I need to rebuild a database or something?

      Jonathan

      Comment


      • #4
        It should work if you have not made any modification to break this.

        To troubleshoot this, remove any hacks and disable your plugins, then see if you still have this problem.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file.

        Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          No mods, fresh install, no plugins or hacks. Default style. Just can't get it to work. What's really weird is that someone else uploaded several images yesterday in another thread and they all displayed. But a couple other people have uploaded multiple pictures and they don't work. So some work and some don't.

          Here is the thread:

          http://www.uwphotochat.com/forums/showthread.php?t=14

          What do you see? I see links, not pictures. Is it me?

          Jonathan

          Comment


          • #6
            Hmmm..I really don't see how this could be if you changed this setting. Fill out a support ticket at:

            http://members.vbulletin.com/members...ontactform.php

            Be sure to include the login info to your Admin CP, phpMyAdmin and FTP. Please also include a complete description of the problem.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I switched it over to thumbnail mode to try that out for a while. Not sure which I prefer. The thumbnail mode works.

              Jonathan

              Comment


              • #8
                I prefer thumbnails myself. I hate loading a thread with lots of full-size pictures that I may not want to view.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I'd like to reopen this issue. I've the exactly the same thing happening to me as Birdman.

                  I've disabled thumbnails, I get an image in the post if one image is added but get links if more than one is added.

                  Thanks, Harry

                  Comment


                  • #10
                    And you have done as Steve suggested above?

                    Admin CP -> vBulletin Options -> Message Attachment Options -> View Attached Images Inline -> Yes

                    If so, I think we have a bug!

                    Comment


                    • #11
                      Yes, and prior to setting that up I was only getting links.

                      Harry

                      Comment


                      • #12
                        The setting appears to be backwards (at least in 3.6.0 - can't confirm other versions). Go to Admin CP -> vBulletin Options -> Message Attachment Options -> View Attached Images Inline
                        and set it to "Yes, if post has only one attachment." That displays all attached images inline. Setting it to "Yes" only displays an image inline if it's the sole attachment.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X