Announcement

Collapse
No announcement yet.

Error in Upgrading to 3.6 from 3.5.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in Upgrading to 3.6 from 3.5.4

    ok I am a total noob and beleive this was my error but when I went to upgrade from 3.5.4 to 3.6 somewhere along the lines my original config.php file got overwritten by the new one...at first I thought this was ok due to the included readme file. But after reading one of the manulas on this site it said I did not need to. Now when I try to go to config the new updrages or access my forums for anything all I get is a Database error.

    I am in fear of loosing all our posts/threads etc if I have to do a full install and it wipes everything.

    Is ther any advice/help etc anyone can lend me?

  • #2
    It's OK to replace the config file, just make sure you enter the same MySQL information or you are likely to get database errors. The errors should go away once you enter the correct MySQL info into the file.

    Comment


    • #3
      thank ye much..I'll give that a try

      Comment


      • #4
        ok luck would have it I had a backup of my original config.php file that had been edited for installation.

        Now the problem I am getting when trying to use that url I am told to do for upgrading I get this database error that shows up at the bottom in a window:

        Database error in vBulletin :
        mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
        /hsphere/local/home/gileean/legendsofwinternight.com/forums/includes/class_core.php on line 271
        MySQL Error :
        Error Number :
        Date : Tuesday, August 15th 2006 @ 02:29:36 PM
        Script : http://www.legendsofwinternight.com/...ll/upgrade.php
        Referrer :
        IP Address : 69.150.3.150
        Username :
        Classname : vb_database

        Comment


        • #5
          That error means the MySQL info in the config file is wrong. Check the info again. Your host should be able to confirm the correct info if you continue to have problems.

          Comment


          • #6
            ok got a change in it but now when I reload the page I get this:

            Fatal error: Call to undefined function: mysqli_init() in /hsphere/local/home/gileean/legendsofwinternight.com/forums/includes/class_core.php on line 1021

            Comment


            • #7
              That is a PHP function. It looks like your PHP installation is not compiled with MySQL support, so it needs to be recompiled with that support. You should contact your host about this.

              Comment

              Loading...
              Working...
              X