Announcement

Collapse
No announcement yet.

3.6 error, site was running then this....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.6 error, site was running then this....

    This a site issue or server issue?


    Database error in vBulletin :

    mysql_connect(): User yesfan1_yesfan1 has already more than 'max_user_connections' active connections
    /home/yesfan1/public_html/includes/class_core.php on line 271

    MySQL Error :
    Error Number :
    Date : Tuesday, July 11th 2006 @ 07:44:47 PM
    Script : http://yesfans.com/forumdisplay.php?f=35
    Referrer : http://yesfans.com/
    IP Address : 67.183.196.89
    Username :
    Classname : vb_database
    Tim L
    www.yesfans.com

  • #2
    Server / host problem .. happens to me on occasions

    Comment


    • #3
      This is a limit imposed on you by your host. The server has maxed out the number of MySQL connections your host allows you to have, i.e., 'max_user_connections'.

      You can try turning persistent connections off in your config.php:
      PHP Code:
      // ****** PERSISTENT CONNECTIONS ******
      // This option allows you to turn persistent connections to MySQL on or off.
      // The difference in performance is negligible for all but the largest boards.
      // If you are unsure what this should be, leave it off.
      // 0 = Off; 1 = On
      $usepconnect 0
      But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I was not seeing this as much till I went to 3.6 from 3.0.3
        Tim L
        www.yesfans.com

        Comment


        • #5
          already set to 0!
          Tim L
          www.yesfans.com

          Comment


          • #6
            It has nothing to do with the vb version. It is just the amount of users who are online and make connections. You've reached the max, request your hosting provider to increase the max connections value (usually default 100) to a higher number, like 150 or 250.

            Comment


            • #7
              This is what my server owner is telling me. They also say I am set at 500 conenctions which I am not hitting.
              --------------------

              This is usualy generated when the programs running on your accound try to maintain 30+ connections to mysql at the same time. Please try the following:

              1) Make sure the programs are not trying to use persistant connections

              2) If you programmed the applications, condense multiple queries into simpler, consolidated querries.

              3) If not, contact the creator of the software via forums, mailing lists, etc.

              In any case, I am going to restart mysql to purge all existing connections. This should fix your problem for the time being.
              Tim L
              www.yesfans.com

              Comment


              • #8
                They are wrong. If you were not hitting whatever limit they imposed, then you would not be getting this error.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  OK they have uped my connections,

                  Tim,

                  I've increased the number of allowed mySQL connections on this server to help. Please make sure that whatever script you're using is properly closing out mySQL sessions so that this can avoid hitting any connection limits.
                  ................

                  ANything I can do with my settings to ensure sonnections are closing correctly?
                  Tim L
                  www.yesfans.com

                  Comment


                  • #10
                    If you followed the instructions in post #3 and are not running any hacks or plugins, you have done all you can.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    Loading...
                    Working...
                    X