Announcement

Collapse
No announcement yet.

db error upgrading from 3.0.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • db error upgrading from 3.0.6

    During testing I ran the 3.5.x upgrade on a copy of my 3.0.6 db with no problem, but when I try to run the 3.6 beta 2 upgrade on the same copy I get this db error on the first step:

    Code:
    Database error in vBulletin :
    
    Invalid SQL:
    SELECT varname, value, datatype FROM setting;
    
    MySQL Error  : Unknown column 'datatype' in 'field list'
    Error Number : 1054
    Date         : Sunday, June 25th 2006 @ 10:28:21 AM
    Script       : http://plato/forum/install/upgrade_307.php?step=1
    Referrer     : http://plato/forum/install/upgrade_307.php?rand=67
    IP Address   : 192.168.1.101
    Username     : 
    Classname    : vb_database
    Screenshot attached.
    Attached Files

  • #2
    I can't find that query in my copy of upgrade_307.php for beta 2. Try reuploading the original files.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I'm getting the same exact error trying to upgrade 3.0.6 with 3.6b3
      Sites I Run: Motorola Droid / Verizon Droid Forum, Nexus One Forum, iPhone News, Wii News & Wii Forum, HTC EVO Forum, iPad Forum, iPhone 4 Forum, Android Forum, Sprint Android Forum, AT&T Android Forum, T-Mobile Android Forum, Droid X Forum, HTC Incredible Forum.

      Comment


      • #4
        Please start your own thread.

        P.S. That query does not exist in the default file.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I'm pretty sure this is a bug in the upgrade script.
          Best Regards
          Colin Frei

          Please don't contact me per PM.

          Comment


          • #6
            I don't have that query in my upgrade_307.php file either, yet there it is!

            Comment


            • #7
              Most likely this is coming from an included file, and it's happening when trying to run the build_options() function.
              Best Regards
              Colin Frei

              Please don't contact me per PM.

              Comment


              • #8
                I opened a bug report for this but it's apparently already been reported and fixed (presumably in beta 3).

                Comment


                • #9
                  Still getting the same error with Beta 3. Tried editing the upgrade.php per Freddie's note on the bug report linked above, but that didn't work either. Tried to run the query manually (also per Freddie's bug post) and got a syntax error.

                  Since the original bug report is closed and mine is marked 'duplicate', I'm not sure where to report this.

                  Comment


                  • #10
                    You got the same error with Beta 3? What's the link to your bug report?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      If you're running the query you may have to add a table prefix if you're using one.
                      Best Regards
                      Colin Frei

                      Please don't contact me per PM.

                      Comment


                      • #12
                        Yep, same error with Beta 3. Even after restoring the db again and starting with a fresh set of files. My bug report is here, the link to the original (beta 2) bug report can be found there.

                        I don't have a prefix on my tables. This is the query Freddie suggested:

                        Code:
                        ALTER TABLE setting ADD datatype datatype ENUM('free', 'number', 'boolean', 'bitfield', 'username') NOT NULL DEFAULT 'free'
                        ...and the error I get when I try to run it:

                        Code:
                        [B]MySQL said: [/B]  
                           #1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'datatype ENUM('free', 'number', 'boolean', 'bitfield', 'usernam

                        Comment


                        • #13
                          datatype is duplicate.
                          Try this query:
                          ALTER TABLE setting ADD datatype ENUM('free', 'number', 'boolean', 'bitfield', 'username') NOT NULL DEFAULT 'free';
                          Best Regards
                          Colin Frei

                          Please don't contact me per PM.

                          Comment


                          • #14
                            Y'know I thought that might be the case. After running that query the install proceeds without a problem. Thanks!

                            Comment


                            • #15
                              I got the same thing on my first step from 3.0.3, ran query listed later in thread, all ok till ..
                              /install/upgrade_350b1.php?step=7


                              MySQL Error : Table 'yesfan1_yesfan12forumsql.podcast' doesn't exist
                              Error Number : 1146
                              Date : Tuesday, July 11th 2006 @ 02:06:57 PM
                              Script : http://www.yesfans.com/forum/install...0b1.php?step=7
                              Referrer : http://www.yesfans.com/forum/install...0b1.php?step=6
                              IP Address : 24.29.18.51


                              PODCAST???? HUH.... lookign for this error now...
                              Tim L
                              www.yesfans.com

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X