Announcement

Collapse
No announcement yet.

Calendar options not saving / admin permissions odd

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Calendar options not saving / admin permissions odd

    I'm having a bit of a problem with the calendar features not saving. I installed and uninstalled a modification which apparently deleted some columns in the database or something since none of the calendar options are saving.

    I have gone into the Calendar Manger and tried to change the settings and none of them are being saved. Right now our calendar only shows Monday - Friday and when we try to allow it to show Weekends, it doesn't save nor does it change anything on the calendars.

    This is our calendar structure, please tell me if there is something that has changed:

    Code:
    CREATE TABLE IF NOT EXISTS `vb_calendar` (
      `calendarid` int(10) unsigned NOT NULL auto_increment,
      `title` varchar(255) NOT NULL default '',
      `description` varchar(100) NOT NULL default '',
      `displayorder` smallint(6) NOT NULL default '0',
      `neweventemail` varchar(255) NOT NULL default '',
      `moderatenew` smallint(6) NOT NULL default '0',
      `startofweek` smallint(6) NOT NULL default '0',
      `options` int(10) unsigned NOT NULL default '0',
      `cutoff` smallint(5) unsigned NOT NULL default '0',
      `eventcount` smallint(5) unsigned NOT NULL default '0',
      `birthdaycount` smallint(5) unsigned NOT NULL default '0',
      `startyear` smallint(5) unsigned NOT NULL default '2000',
      `endyear` smallint(5) unsigned NOT NULL default '2006',
      `holidays` int(10) unsigned NOT NULL default '0',
      PRIMARY KEY  (`calendarid`),
      KEY `displayorder` (`displayorder`)
    ) ENGINE=MyISAM  DEFAULT CHARSET=latin1 AUTO_INCREMENT=12 ;
    Does anyone know what I can do to get these to save?

    Another thing, our admin permissions (usergroups > admin permissions) seem to be a little bit odd in that when I go to edit the permissions they only say N/A with the radio button set to No.

    Ideas?

    Update: I have restored the files and database from a previous version and things are still not saving correctly in the admin CP. It's almost like there's some sort of cookie problem? I'm not sure how else to explain it.
    Last edited by aymelek; Wed 25th May '11, 5:45am.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X