Announcement

Collapse
No announcement yet.

Restoring old Database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Glad to hear it.

    Leave a comment:


  • OrangeFlea
    replied
    Wow, it worked.

    Both of your suggestions actually saved me. Steve, I forgot to add the no_plug-ins string to the newly uploaded config.php file (I did it on the previous uploaded file, however), and Uncoder Mom, I took a second look at the master database name and discovered that entered incorrect information.

    Thank you both. I was on the verge of losing years worth of hard work, but you two saved the day. Thank you so much.

    Leave a comment:


  • UncoderMom
    replied
    Originally posted by UncoderMom View Post
    I "think" you need to assign a user to the database. From your myphpadmin panel and then add it to your config.php too. Have you created a user for the database with a password?

    I see he told you to do that but you have not said that you did....???
    yeah, never mind.. I just read the second error which would indicate a valid failed connection.

    sorry, that wasnt helpful. LOL

    Leave a comment:


  • Steve Machol
    replied
    It looks like the problem is that this database is not complete. If it were complete then you would not get an error about an unknown column. If the db were correctly backed up and restored, it would function exactly as before, assuming you are also using files for the same vB version.

    Unfortunately I do not know how to fix this without a good backup.

    Leave a comment:


  • UncoderMom
    replied
    Originally posted by OrangeFlea View Post
    My webhost, upon my request, restored a vBulletin 3.5.4. dump into a database. I did a back-up of the forum last year. He sent this:



    The part in bold is what I'm trying to do. I'm trying to restore and activate the old forum (3.5.4). I've re-uploaded 3.5.4 files because the original files were not saved, just the database.

    But I've run into issues. My latest one being this:



    Now, I don't know what to do to get the 3.5.4 board back (so I can then upgrade to 3.7).

    To summarize, this is what I've done:

    1.) Restored the dump (vB forum 3.5.4)
    2.) Uploaded 3.5.4 files (did not run the installation file)
    3.) edited config.php to point to the database name (maddux_forum)

    So what do I do now?
    I "think" you need to assign a user to the database. From your myphpadmin panel and then add it to your config.php too. Have you created a user for the database with a password?

    I see he told you to do that but you have not said that you did....???

    Leave a comment:


  • OrangeFlea
    replied
    My webhost, upon my request, restored a vBulletin 3.5.4. dump into a database. I did a back-up of the forum last year. He sent this:

    I have restored the dump into a database named "maddux_forum". You will need to modify your forums database configuration to use this database, and you will need to create a new database user and grant it access to this database through the cPanel MySQL Manager.
    The part in bold is what I'm trying to do. I'm trying to restore and activate the old forum (3.5.4). I've re-uploaded 3.5.4 files because the original files were not saved, just the database.

    But I've run into issues. My latest one being this:

    Invalid SQL:

    SELECT cron.*
    FROM cron AS cron
    LEFT JOIN product AS product ON (cron.product = product.productid)
    WHERE cron.nextrun <= 1214856315 AND cron.active = 1
    AND (product.productid IS NULL OR product.active = 1)
    ORDER BY cron.nextrun
    LIMIT 1;

    MySQL Error : Unknown column 'cron.active' in 'where clause'
    Error Number : 1054
    Date : Monday, June 30th 2008 @ 04:05:15 PM
    Script : http://www.xxxx.com/forum/cron.php?rand=506450
    Referrer :
    IP Address : xxxxxxxx
    Username : Unregistered
    Classname : vb_database

    To summarize, this is what I've done:

    1.) Restored the dump (vB forum 3.5.4)
    2.) Uploaded 3.5.4 files (did not run the installation file)
    3.) edited config.php to point to the database name (maddux_forum)

    So what do I do now?

    Leave a comment:


  • Steve Machol
    replied
    What do you mean by 'restore'? Please provide all the relevant info.

    Leave a comment:


  • OrangeFlea
    replied
    How am I supposed to upgrade (which is what I want to do) when the database I need to restore is 3.5.4? I'll need 3.5.4 files in order to bring it back, and then upgrade to 3.7.2, but first I need 3.5.4 assistance....

    How am I supposed to do anything at this point without 3.5 support?

    Leave a comment:


  • Steve Machol
    replied
    <moved>

    Unfortunately I do not have a vB 3.5 database to check this with.

    As per this announcement please note the vB 3.5.x has reached it's end of life and is no longer actively developed or supported:

    http://www.vbulletin.com/forum/showthread.php?t=268829

    We strongly recommend that anyone running 3.5.x upgrade to the latest stable version as soon as possible.

    Leave a comment:


  • OrangeFlea
    replied
    I feel like an idiot, Steve. I apologize for inconveniencing you. The old vb database was actually running 3.5.4, when I thought it was running 3.6, which is why I uploaded 3.6 files.

    Well, I removed all the 3.6 files and replaced them with those of 3.5.4 (still did not run the installation script). However, I'm now getting this error:

    Invalid SQL:

    SELECT cron.*
    FROM cron AS cron
    LEFT JOIN product AS product ON (cron.product = product.productid)
    WHERE cron.nextrun <= 1214856315 AND cron.active = 1
    AND (product.productid IS NULL OR product.active = 1)
    ORDER BY cron.nextrun
    LIMIT 1;

    MySQL Error : Unknown column 'cron.active' in 'where clause'
    Error Number : 1054
    Date : Monday, June 30th 2008 @ 04:05:15 PM
    Script : http://www.xxxx.com/forum/cron.php?rand=506450
    Referrer :
    IP Address : xxxxxxxx
    Username : Unregistered
    Classname : vb_database
    PS: I know you're now obligated to move this thread to the vb 3.5 section, but I could still very much use your assistance....

    Leave a comment:


  • Steve Machol
    replied
    Which version of vB is this?

    Leave a comment:


  • OrangeFlea
    replied
    Just did so. Reuploaded fresh vB files, and now I get this:

    Invalid SQL:

    SELECT
    user.username, (user.options & 512) AS invisible, user.usergroupid,
    session.userid, session.inforum, session.lastactivity,
    IF(displaygroupid=0, user.usergroupid, displaygroupid) AS displaygroupid,
    infractiongroupid
    FROM session AS session
    LEFT JOIN user AS user ON(user.userid = session.userid)
    WHERE session.lastactivity > 1214854697
    ORDER BY username ASC;

    MySQL Error : Unknown column 'infractiongroupid' in 'field list'
    Error Number : 1054
    Date : Monday, June 30th 2008 @ 03:53:17 PM
    Script : http://www.xxx.com/forum/
    Referrer :
    IP Address : xxxxx
    Username : Unregistered
    Classname : vb_database

    Leave a comment:


  • Steve Machol
    replied
    1. This error is from a plugin you've installed. You need to disable each of your plugins then turn one at a time to see which one is causing this.

    If you cannot log into the Admin CP then to disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    This will disable all hooks and allow you to log in properly with no hooks running.

    http://www.vbulletin.com/docs/html/disable_plugins

    2. Reupload the original vB files.

    Leave a comment:


  • OrangeFlea
    replied
    Warning: Unknown(/home/xxx/public_html/forum/includes/synergy.php): failed to open stream: No such file or directory in /includes/init.php(317) : eval()'d code on line 5

    Fatal error: (null)() [function.require]: Failed opening required '/home/xxx/public_html/forum/includes/synergy.php' (include_path='/usr/lib/php:.:/usr/php4/lib/php:/usr/local/php4/lib/php') in /home/xxx/public_html/forum/includes/init.php(317) : eval()'d code on line 5

    ^^^ that's on the forum front page now

    Leave a comment:


  • Steve Machol
    replied
    We need to see the real error message. Right-click on the error page and go to View/Source. Then copy-n-paste the error message here.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X