Announcement

Collapse
No announcement yet.

Restoring old Database

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by OrangeFlea View Post
    My webhost, upon my request, restored a vBulletin 3.5.4. dump into a database. I did a back-up of the forum last year. He sent this:



    The part in bold is what I'm trying to do. I'm trying to restore and activate the old forum (3.5.4). I've re-uploaded 3.5.4 files because the original files were not saved, just the database.

    But I've run into issues. My latest one being this:



    Now, I don't know what to do to get the 3.5.4 board back (so I can then upgrade to 3.7).

    To summarize, this is what I've done:

    1.) Restored the dump (vB forum 3.5.4)
    2.) Uploaded 3.5.4 files (did not run the installation file)
    3.) edited config.php to point to the database name (maddux_forum)

    So what do I do now?
    I "think" you need to assign a user to the database. From your myphpadmin panel and then add it to your config.php too. Have you created a user for the database with a password?

    I see he told you to do that but you have not said that you did....???

    Comment


    • #17
      It looks like the problem is that this database is not complete. If it were complete then you would not get an error about an unknown column. If the db were correctly backed up and restored, it would function exactly as before, assuming you are also using files for the same vB version.

      Unfortunately I do not know how to fix this without a good backup.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #18
        Originally posted by UncoderMom View Post
        I "think" you need to assign a user to the database. From your myphpadmin panel and then add it to your config.php too. Have you created a user for the database with a password?

        I see he told you to do that but you have not said that you did....???
        yeah, never mind.. I just read the second error which would indicate a valid failed connection.

        sorry, that wasnt helpful. LOL

        Comment


        • #19
          Wow, it worked.

          Both of your suggestions actually saved me. Steve, I forgot to add the no_plug-ins string to the newly uploaded config.php file (I did it on the previous uploaded file, however), and Uncoder Mom, I took a second look at the master database name and discovered that entered incorrect information.

          Thank you both. I was on the verge of losing years worth of hard work, but you two saved the day. Thank you so much.

          Comment


          • #20
            Glad to hear it.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X