Announcement

Collapse
No announcement yet.

Secondary Group Permissions problem (HELP)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Secondary Group Permissions problem (HELP)

    I am having some issues with gorup permissions using seconary groups.

    The issue is that if a members is part of the standard registered users group and I add them to a new gorup called "TESTING" and choose this group as the secondary gorup the access masks are working good.

    The issue is if a Premium Members group members is added the "TESTING" group for there secondary group which has access to some hiden forums has they still cant access or see the hidden forum that the TESTING group has permissions to see? What am I doing wrong? I have checked my Access Masks many times already?

  • #2
    I'm not sure I follow that but main Usergroup Permissions take precedence unless you override them with specific Forum/Usergroup permissions.

    When multiple usergroups are involved, a 'Yes' permission always overides a 'No' permission if 'Allow Users to have Member Groups ' is set to 'Yes' for the Primary group. Same goes for a larger quota.

    Note, the primary group must have 'Allow Users to have Member Groups' to 'Yes'. Otherwise the secondary settings are not applicable.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve,

      I have dont exactly as you mentioned. My Primary usergroup is set to 'Allow Users to have Member Groups ' is set to 'Yes' and the Secondary Group they are assigned to has access to a specific forum that the Primary Usergroup does not. I have also modified the Forum Permissions to allow the Second Usergroup to "Can View forum, Can view threads content, Can view others threads" and so on but the the members claim that they cant view that the hidden forum that the secondary usergroup is permitted to view.

      NOw if I go to Forum Manager and choose the hidden forum properties and I add the members emails address where it says Email Addresses to Notify When there is a New Post & Email Addresses to Notify When there is a New Thread and there is a new post they will get the email alert and when they click the forum link they can access the forum but they just cant see the forum listed with all the other forums? Can you help me with this please

      Comment


      • #4
        Sorry I couldn't understand your last post. What is the exact problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Steve,

          Not sure how simple I can explain this..

          I have a usergroup called Premium Members that does not have access to a hidden forum I created. I have create another usergroup called Team XX which DOES have access to the hidden forum.

          Now if I go to user manager and edit a members usergoup option that is currently part of the Premium Members group as there primary gorup and I add this member to the Team XX group as their additional usergroups this is where the isues is. Even though there second group has access to view and other things in the hidden forum, the members still cant see the forum

          Comment


          • #6
            This will work if the Team XX group group has 'Allow Users to have Member Groups' set to 'Yes' and you have not installed any add-ons or modifications.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              yes both primary and secondary has 'Allow Users to have Member Groups' to yes but they still have view the forum..

              Comment


              • #8
                What do you mean 'they still have view the forum'?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  What do you mean 'they still have view the forum'?

                  What I meant to say was "They still cant view the forum...

                  Comment


                  • #10
                    This is either a problem with your permissions, or something caused by an add-on. This does work with the correct permissions and the original vB code.

                    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

                    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

                    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

                    Next, disable all plugins.

                    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                    define('DISABLE_HOOKS', true);

                    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      There is no way I can do this to a production site with over 5K members. Any other ideas?

                      Comment


                      • #12
                        Why not?
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X