Announcement

Collapse
No announcement yet.

'mysqladmin flush-hosts'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 'mysqladmin flush-hosts'

    how to fix this issue ?

    Database error in vBulletin :

    mysql_connect(): #HY000Host '208.98.1.82' is blocked because of many
    connection errors; unblock with 'mysqladmin flush-hosts'
    /home/psa/home/vhosts/dardania.de/httpdocs/vb/upload/includes/class_core.php
    on line 279

  • #2
    You (as root) or your host will have to run this at the command line:

    mysqladmin flush-hosts
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Ok, i did it. The forum runs for 3-4 hours fine then this problem appears again.

      Furthermore i have set the max. connection error on 9999999

      safe_mysqld -O max_connect_errors=999999999 &
      Last edited by Taralushi; Fri 19 Jan '07, 12:19am.

      Comment


      • #4
        What is your setting for `max_connect_errors'?

        This error is caused by too many interrupted connections.

        If the IP address in the error is not the IP of your webserver, then someone is trying to break into your MySQL.

        Edit: if you are runing MySQL 5, then it could also be a bug: http://bugs.mysql.com/bug.php?id=24761
        Want to take your board beyond the standard vBulletin features?
        Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

        Comment


        • #5
          it is set 999999999

          It is the IP from the server.

          Comment


          • #6
            Try setting it to a more reasonable value, 1024 for example, and restart mysqld.

            Otherwise inspect the mysql logfiles if there is anything in there that could give a bit more info on this.

            What MySQL version are you using?
            Also is MySQL running on the webserver or on another server?
            Want to take your board beyond the standard vBulletin features?
            Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

            Comment


            • #7
              I am using mysql version 4.1.13

              No, the mysql is not running on the webserver it runs on a seperate server.

              I have set the max connection errors to 1024 but still (after 2 days) i am getting the same error message.

              Mysql logfiles do not give any suspicious infos

              Comment


              • #8
                How are the 2 servers connected, using a dedicated network connection?

                Your problems seems to be that you get connection errors to the database server. You (or your host) will need to find the cause of those errors.
                Want to take your board beyond the standard vBulletin features?
                Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X