Announcement

Collapse
No announcement yet.

URL's in Postbit...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • URL's in Postbit...

    Is there a particular setting that turns the .../ url shortening or off? maybe more setting options for it?

    I have a problem where only some of the time when users post URL's in replies/threads are shortened with the .../ in the URL.

    I notice that most of those times when it doesn't its because a user is writing their reply/thread in larger or different colored font through the entire post... The other thing that happens is when you do a "Find all posts by user" that the search result page with their posts also doesn't truncate the long URLS...


    If anyone can help me i'd appreciate it, the way our forum is designed it really mucks up the entire look when postbit or search results bleeds into our other columns.. help! why is it so sporadic on which urls it shortens!

  • #2
    Wanted to ask if this be moved to the vb3.5 How Do I section.

    Regards.

    Comment


    • #3
      Sorry I don't understand what you are asking. Please explain.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        When a user creates a new thread or replies to another thread with a long URL it will truncate.

        Example:

        http://www.foo.bar/this/is/a/long/ur...sttesttesttest

        You will notice after a certain amount of characters in the URL it will put ... and shorten the URL within the post/thread so the postbit doesn't keep scrolling over to the right of the site.

        My problem is that this automated URL shortening only works some of the time on my board. Users that seemingly use all color for their text are exempt from the URL being shortened, not sure why.

        The only other time I see this happen is when you view a users posts
        "Find all posts by ExampleUser". When you view a users posts like that it basically uses the search results page to display their posts. This page also does not truncate (shorten) the long url's they might have in one of their posts.

        I hope this helps, if not i'll start doing screenshots.

        Thanks for your reply.

        Comment


        • #5
          That is normal and always has been. What is the specific problem with this? Can you dupliayte any problems on these forums? If so, please do so in this thread.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            The problem is that the shortening function only happens sometimes... one minute a user will post an ebay link that works with the URL shortening.

            The next day they may come on and post more long URL's and they don't truncate and it literally shows the entire URL no matter how long it is.

            I would say it has something to do with a hack perhaps but I don't have any hacks that directly effect URL's in threads at all. No nofollow hacks for links, nothing.

            Comment


            • #7
              Yes, and my question was can you reproduce this here and if so please do it in this thread so I can see for myself.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I tried duplicating this in the testing section and it doesn't seem to happen here.. i'll try again.

                http://cgi.ebay.com/ebaymotors/Ford-...spagenameZWDVW

                -- edit --

                Weird, it won't do it here... The odd thing is that Vbulletin.com actually strips the BBcode color off the url, is that new? On my forum (3.5.4) people can post links and they will be the color that the person is typing with. I tried to make the URL above the burgandy color but it won't allow the link to change colors.

                This is semi important because the only time I see URL's not shortening is when they have colors on them.

                Comment


                • #9
                  If it doesn't happen here then I would say this is being caused by a modification you made to either the templates or with an add-on.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks for the input. Can you clue me in on if the color URL's is new? Does 3.6 have a function that strips bbcode colors off of URL's now?

                    My forum even from a fresh install always allowed colored URL's on it.

                    Comment


                    • #11
                      AFAIK you could always use colors in URLs.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Ah i found it!

                        Watch this


                        http://cgi.ebay.com/ebaymotors/Ford-Mustang-2006-FORD-MUSTANG-ROUSCH-STAGE-3-BRAND-NEW-LOADED-L-K_W0QQcmdZViewItemQQcategoryZ6236QQhashZitem300067076853QQihZ020QQitemZ300067076853QQrdZ1Q QsspagenameZWDVW


                        Here is the same link in plain non altered text and it works just fine

                        http://cgi.ebay.com/ebaymotors/Ford-...spagenameZWDVW


                        So as you can see if you have a long url that someone alters with color or size it completely removes any URL shortening functions from happening.. I knew I wasn't crazy..

                        Comment


                        • #13
                          Thanks. Please report this in the 3.6 Bug Tracker here:

                          http://www.vbulletin.com/forum/bugs36.php
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Submitted.

                            This bug applies to 3.5.4 and 3.6 I suppose since it broke this postbit to.


                            Regards.

                            Comment

                            Loading...
                            Working...
                            X