Announcement

Collapse
No announcement yet.

Usergroup + display name problem after import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Yep, I noticed the same thing. ^^^

    Leave a comment:


  • fridaypassion
    replied
    just found what it was, you have to have the "Can override primary group title/markup" to Yes (it defaults to No)

    Thanks for your help anyway Steve its helped me get my head round the system a bit more!

    Leave a comment:


  • Steve Machol
    replied
    Oops - also make sure that 'Can override primary group title/markup' is set to 'Yes' for the secondary group. Sorry I missed that!

    Leave a comment:


  • Steve Machol
    replied
    Nope, it should be there assuming the primary group has "Allow Users to have Member Groups" set to 'Yes' and you have not made any modifications to break this.

    Leave a comment:


  • fridaypassion
    replied
    Hi

    There is no group memberships option in the userCP. This is with a user that is in registered users and a secondary usergroup "club members"

    Could this be due to the club members being in additional users not primary users?

    Leave a comment:


  • Steve Machol
    replied
    User CP -> Group Memberships

    Leave a comment:


  • fridaypassion
    replied
    Hi Steve, where in the CP do users select their usergroup? I have made the changes to the usergroups as above but in my test user profile I cant find an option for choosing usergroups?

    Thanks

    Leave a comment:


  • Steve Machol
    replied
    You have to have "Allow Users to have Member Groups" set to 'Yes' for the Primary group. Then your memnbers will be able to chose which group they want to be associated with in their User CPs.

    Leave a comment:


  • fridaypassion
    replied
    ok sorry let me explain again,

    I have just completed an import from pbpbb. On my pbpbb forum I had two usergroups. Group 1 was registered users and group 2 was for paid members.

    When I have imported the forum to VBB I now have all members in registered users and my paid members are also in an additional group called paid members.

    My registered users have a User title of "Forum User"

    My paid member usergroup has a title of "Club member" I have set the user title of that usergroup to "Club member"

    The users which are members of both groups hopwever still have the custom title of "forum user" and I cant get the "club member" user title to show on their posts. I have tried all variations of the "Allow Users to have Member Groups" settings with no success.

    The other anomoly which I said may be having an effect is that in the Club member usergroup which was imported from phpbb all the users are "additional users" wheras all my registered users are "Primary users" I dont know if that will affect the permissions setup to stop what I'm trying to do?

    Leave a comment:


  • Steve Machol
    replied
    I'm sorry but try as I might I cannot understand what you are asking and why our previous responses are not applicable. All the available Usergroup permissions are outlined in post #4. You might want to try explaining again.

    Leave a comment:


  • fridaypassion
    replied
    bump

    Leave a comment:


  • fridaypassion
    replied
    the problem is the move usergroup feature doesnt pick up my paid members as they are in "additional users" not "primary users"

    Leave a comment:


  • Floris
    replied
    You can move users from one group to another. If you have a custom usergroup A and paid usergroup A, you can move the custom usergroup members to the paid usergroup. Before deleting the custom usergroup.

    Leave a comment:


  • fridaypassion
    replied
    Hi

    Thanks for the reply, I had previously done those settings but the custom title always remains "forum user" which is the title for general users and those settings dont overide that custom title with the "club member" title that the club member usergroup has. I guess this has something to do with all my "club members" being imported into additional users rather than primary users? I tried manually adding a couple of users into the primary section of that usergroup and that did overide the custom title setting

    Leave a comment:


  • Steve Machol
    replied
    Normally yes, but you could just edit the Usergroup settings and permissions accordingly instead and you seemed to indicate that you were having a problem doing this.

    First check the overall Usergroup permissions and settings:

    Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup

    Then the Forum permissions for each forum and Usergroup:

    Admin CP -> Forums & Moderators -> Forum Permissions

    Keep in mind that main Usergroup Permissions take precedence unless you override them with specific Forum/Usergroup permissions.

    When multiple usergroups are involved, a 'Yes' permission always overides a 'No' permission if 'Allow Users to have Member Groups ' is set to 'Yes' for the Primary group. Same goes for a larger quota.

    Note, the primary group must have 'Allow Users to have Member Groups' to 'Yes'. Otherwise the secondary settings are not applicable.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X