Announcement

Collapse
No announcement yet.

Usergroup + display name problem after import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Usergroup + display name problem after import

    I have just completed an import of a forum over from phpbb2
    . Basically (on my old forum) I had two usergroups. The first usergroup was a general group for all registered users, then if people paid a subscription they were upgraded to "Club member" status and given access to certain areas of the forum.

    Since the import ALL users are in the usergroup "Active Imported Users" and the previous paid members are in the "additional users" section of the "club members" custom usergroup as well as the Active imported users group. The display name from the active imported usergroup is coming up on the club members profiles too even though I have changed that group display name to "club members"

    Also despite setting access permissions for the paid "club member" usergroup I am getting these users saying they can't access the forums I have set permissions for. Is this because they are only in the "additional users" section of the usergroup not the primary users section? Can you move users between the two?

  • #2
    Did you follow the 'After the Import' instructions here:

    http://www.vbulletin.com/docs/html/impex_cleanup
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I havent deleted the custom usergroups no, If I delete the custom usergroups will I then need to manually add my paid users into a new usergroup within the default usergroups?

      Comment


      • #4
        Normally yes, but you could just edit the Usergroup settings and permissions accordingly instead and you seemed to indicate that you were having a problem doing this.

        First check the overall Usergroup permissions and settings:

        Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup

        Then the Forum permissions for each forum and Usergroup:

        Admin CP -> Forums & Moderators -> Forum Permissions

        Keep in mind that main Usergroup Permissions take precedence unless you override them with specific Forum/Usergroup permissions.

        When multiple usergroups are involved, a 'Yes' permission always overides a 'No' permission if 'Allow Users to have Member Groups ' is set to 'Yes' for the Primary group. Same goes for a larger quota.

        Note, the primary group must have 'Allow Users to have Member Groups' to 'Yes'. Otherwise the secondary settings are not applicable.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hi

          Thanks for the reply, I had previously done those settings but the custom title always remains "forum user" which is the title for general users and those settings dont overide that custom title with the "club member" title that the club member usergroup has. I guess this has something to do with all my "club members" being imported into additional users rather than primary users? I tried manually adding a couple of users into the primary section of that usergroup and that did overide the custom title setting

          Comment


          • #6
            You can move users from one group to another. If you have a custom usergroup A and paid usergroup A, you can move the custom usergroup members to the paid usergroup. Before deleting the custom usergroup.

            Comment


            • #7
              the problem is the move usergroup feature doesnt pick up my paid members as they are in "additional users" not "primary users"

              Comment


              • #8
                bump

                Comment


                • #9
                  I'm sorry but try as I might I cannot understand what you are asking and why our previous responses are not applicable. All the available Usergroup permissions are outlined in post #4. You might want to try explaining again.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    ok sorry let me explain again,

                    I have just completed an import from pbpbb. On my pbpbb forum I had two usergroups. Group 1 was registered users and group 2 was for paid members.

                    When I have imported the forum to VBB I now have all members in registered users and my paid members are also in an additional group called paid members.

                    My registered users have a User title of "Forum User"

                    My paid member usergroup has a title of "Club member" I have set the user title of that usergroup to "Club member"

                    The users which are members of both groups hopwever still have the custom title of "forum user" and I cant get the "club member" user title to show on their posts. I have tried all variations of the "Allow Users to have Member Groups" settings with no success.

                    The other anomoly which I said may be having an effect is that in the Club member usergroup which was imported from phpbb all the users are "additional users" wheras all my registered users are "Primary users" I dont know if that will affect the permissions setup to stop what I'm trying to do?

                    Comment


                    • #11
                      You have to have "Allow Users to have Member Groups" set to 'Yes' for the Primary group. Then your memnbers will be able to chose which group they want to be associated with in their User CPs.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Hi Steve, where in the CP do users select their usergroup? I have made the changes to the usergroups as above but in my test user profile I cant find an option for choosing usergroups?

                        Thanks

                        Comment


                        • #13
                          User CP -> Group Memberships
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Hi

                            There is no group memberships option in the userCP. This is with a user that is in registered users and a secondary usergroup "club members"

                            Could this be due to the club members being in additional users not primary users?

                            Comment


                            • #15
                              Nope, it should be there assuming the primary group has "Allow Users to have Member Groups" set to 'Yes' and you have not made any modifications to break this.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X