Announcement

Collapse
No announcement yet.

Security patch for 3.5.6?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Security patch for 3.5.6?

    Hello,

    I am currently running vb 3.5.5 and I was wondering which security patch to install. Do I install the patch that says "Security patch for 3.5.5" or the one that Says "Security patch for 3.5.6".

    Because it sounds like because I am running 3.5.5 I would install the 3.5.5. because it says for that version, but in reality I was to have the 3.5.6 latest patch protection.

    I think the wording should say "Security Patch to upgrade to 3.5.6." Can someone let me know on this?


    Thank You,

    Nuguru

  • #2
    In order to update the 3.5.5 with the 3.5.6 security patch you'll have to upgrade to 3.5.6 first.

    If you run 3.5.5 and watch to patch it, install the 3.5.5 patch.
    If you run 3.5.6 and watch to patch it, install the 3.5.6 patch.

    If you wish to have all bugs and issues patched I recommend to upgrade to 3.5.7 or 3.6.4.

    Comment


    • #3
      Patch or Upgrade ?

      Hello,

      Oh, now I am getting confused. Okay, Let me start from the beginning.

      Initially I installed vb 3.5.4. Then the 3.5.5. security patch came along, so I installed that. Therefore I believe now I am running 3.5.5. right?

      Now that I am running 3.5.5., don't I want to install the 3.5.6. patch? Or is there a 3.5.7. patch that I can go right to from when I installed the 3.5.5.?

      Now your talking about upgrade? Is there a difference between patch and upgrade? Or is the upgrade the patch? Are they the samething?

      Like I said, in the beginning I installed 3.5.4., then put in the 3.5.5. patch. I don't want to go to 3.6X and I want to stay with 3.5X, so what actual patch do I install? Do I install 3.5.5., then 3.5.6., and if there is a 3.5.7 install that. Or can I install 3.5.6. or 3.5.7.

      Still a bit confused here, can you spell it out and tell me what patch to install for max security with the 3.5x series?


      Thank You,

      Nuguru

      Comment


      • #4
        The patches are only verified to work with the preceeding version. So the 3.5.7 patch will work with 3.5.6 but not necessarily 3.5.5. You need to upgrade to at least 3.5.6 as Floris stated. And if you are going to do that you might as well upgrade to 3.5.7 and then no patches will be needed.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Don't want to Upgrade to 3.5.7

          Hello,

          Okay, it seems that to upgrade to 3.5.7 I have to basically download and install the entire 3.5.7 package. I don't want to do that.

          Again, I initially installed vb 3.5.4 and then installed the 3.5.5. patch later when it came out. Now I just want to patch 3.5.5. So, which one of these patches do I download and install. A or B ?

          A. Security patch for 3.5.6 (included in 3.5.7+)

          B. Security patch for 3.5.5 (included in 3.5.6+)


          Thank You,

          Nuguru

          Comment


          • #6
            You cannot patch 3.5.5. Sorry I did make that clear.

            Please view the upgrade documentation here:

            http://www.vbulletin.com/docs/html/upgrade/
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Is 3.5.5. Unsecure?

              Hello,

              Okay that makes sense now.

              So, does that mean that people running vb3.5.5. are unsecure and are vulnerable to this security threat of cross scripting in the ACP?


              Thank You,

              Nuguru

              Comment


              • #8
                Yes, to the exploit that was fixed in 3.5.7.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  If you have 3.5.4 installed and patched for 3.5.5. Then you are still running 3.5.4.

                  The patches for 3.5.6 and 3.5.7 are for 3.5.5 and 3.5.6 and shouldn't be used on 3.5.4.

                  To run 3.5.7 you simply have to upgrade.

                  Comment

                  Related Topics

                  Collapse

                  Working...
                  X