Announcement

Collapse
No announcement yet.

Problem with the upgrade "sql error"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with the upgrade "sql error"

    Hi
    I am trying to upgrade my 3.5.3 adn everytime I try to run the upgrade script, I get this :
    our vBulletin version does not appear to match with the version for which this script was created (version 3.5.4). Please ensure that you are attempting to run the correct script.
    If you are sure this is the script you would like to run, click here.



    I know that I am running the 3.5.3 so I changed the address to :


    http://www.XXXXX.net/newsr/install/upgrade_354.php

    but when I click on Next Step, I get this sql error:
    Database error in vBulletin 3.5.3:

    Database error in vBulletin 3.5.3:

    Invalid SQL:
    ALTER TABLE subscribethread ADD canview SMALLINT UNSIGNED NOT NULL DEFAULT 1;

    MySQL Error : Duplicate column name 'canview'
    Error Number : 1060
    Date : Wednesday, December 13th 2006 @ 03:56:49 PM
    Script : http://www.xxxxx.net/newsr/install/upgrade_354.php?step=1
    Referrer : http://www.xxxx.net/newsr/install/upgrade_354.php
    IP Address : removed
    Username :
    Classname : vb_database

  • #2
    This means that you have already run this upgrade step before or you have installed an add-on that added a field wihich conflicts with this upgrade.

    You can try deleting the 'canview' field from the subscribethread table in phpMyAdmin.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X