Announcement

Collapse
No announcement yet.

simultaneous merge of threads.... lost one?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • simultaneous merge of threads.... lost one?

    Myself and a mod were merging two threads simultaneously...

    and it appears we lost the posts in one of them.

    Thread #1
    Thread #2

    We were both merging Thread #2 into Thread #1

    Thread #2 link was then pointing correctly to Thread #1

    but none of the posts were moved from Thread #2 to Thread #1. The Thread #2 posts appeared to have disappeared. I then chose "remove redirects" on the final thread to see if that would make Thread #2 reappear... it did not. Now Thread #2 is simply gone.

    I imagine the posts are somewhere in the db... any ideas on how to fix it? track this down?

    arn

  • #2
    sorry. this is a vbulletin 3.6 issue. (posted in wrong subforum)

    arn

    Comment


    • #3
      Honestly I'm having a hard time understanding this. The merge function does work fine on an unmodified vB. Have you installed any hacks or plugins?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Originally posted by Steve Machol View Post
        Honestly I'm having a hard time understanding this. The merge function does work fine on an unmodified vB. Have you installed any hacks or plugins?
        nothing that should affect the merge.

        plug ins: VBSeo Sitemap, Welcome Headers, and some custom minor things.

        If it helps, here's the thread edit log:

        12:03, 12th Dec 2006 longofest Post First Post by ErnieFrance4 Soft Deleted
        12:06, 12th Dec 2006 arn Thread merged with 'Monthly Itunes Sales Have Dropped 65% Since Jan.'.
        12:07, 12th Dec 2006 arn Closed Thread
        12:07, 12th Dec 2006 longofest Closed Thread
        12:07, 12th Dec 2006 longofest Thread merged with 'iTunes sales apparently fown 65%'.
        12:08, 12th Dec 2006 longofest Thread merged with 'iTunes sales apparently fown 65%'.
        12:09, 12th Dec 2006 arn Post by ChickenSwartz Soft Deleted N/A
        12:09, 12th Dec 2006 arn Post by AvSRoCkCO1067 Soft Deleted N/A
        Note the 12:07 and 12:08 merge.

        'iTunes sales apparently fown 65%' was the thread that was lost.

        I looked in the database (post and thread tables) to find remnants of the thread, but they weren't there. I attributed it to Myself (arn) and the mod trying to merge the threads at the same time. You'll notice I merged a thread immediately before. I then tried to merge the subsequent thread also... but the log doesn't appear to reflect my attempt.

        I'll see if I can recreate this situation later tonight.

        arn

        Comment


        • #5
          I can confirm there is at least one bug with the Merge command... I was testing on a (relatively) unmodified install of vbulletin.

          Take two threads.

          Thread #1
          Thread #2

          Merge Thread #2 into Thread #1

          then, do it again

          Merge Thread #2 into Thread #1 again

          In my two test cases, it didn't lose any posts... but it did create an empty poll at the top of the thread after then second merge. This also happened in my "live" thread that developed problems. You can verify by merging twice.

          arn

          Comment


          • #6
            If yyou believe you have found a bug and can duplicate this on an unhacked forum, please report this in the 3.6 Bug Tracker here:

            http://www.vbulletin.com/forum/bugs36.php
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Another potential test case.

              Thread #1
              Thread #2

              I copied the showthread.php?t=xyz url from Thread 2.
              I copied a postlink showpost.php?p=abc url from Thread 2.

              Went to Thread 1 and merged using the showthread url. It merged ok.
              Went to the new Thread 1 again and merged using the showpost.php url. It then merged an unrelated thread and merged it into Thread 1.

              arn

              Comment


              • #8
                Originally posted by Steve Machol View Post
                If yyou believe you have found a bug and can duplicate this on an unhacked forum, please report this in the 3.6 Bug Tracker here:

                http://www.vbulletin.com/forum/bugs36.php
                I submitted it.

                arn

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X