Announcement

Collapse
No announcement yet.

Max Allowed Packet??? ****** Help Please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Max Allowed Packet??? ****** Help Please

    Hello Everyone,

    Okay everything was going great tonight adding forums to my vbulletin 3.5.4 until I got this message "Got a packet bigger than "max_allowed_ packet" bytes (please see attachment - screenshot).

    It looks like my vbulletin 3.5.4 is saying that the packet size that I am sending to MySQLi is to large? But I am not exactly sure what this all means and how to correct it in a safe way.

    So, I called my web hosting service and spoke with a tech. He said the largest packet I can send to my database is 2 mg. I then asked the tech if they could increase it, they said yes but at $75.00/hr. I told him I would hold off and get back to them.

    Unfortunately, I don't know how to increase it myself and I don't even know what is safe to increase the transferrable packet size to for my database.

    If someone could help me out here and first of all tell me what exactly this problem is and then how to correct it on my own. Is there a simple setting that I can change in a particular file?

    Please note that I do not konw how to shell into my server, but I do have root access through Plesk. My server is running on Linux.



    Thanks Again Everyone,

    Nuguru
    Attached Files

  • #2
    If you have root access you should be able to edit this yourself by adding a line like this to the my.ini file:

    max_allowed_packet=8M
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      Thanks for the advice!

      Originally posted by Colin F View Post
      If you have root access you should be able to edit this yourself by adding a line like this to the my.ini file:

      max_allowed_packet=8M
      Hello,

      I took your advice but there was no my.ini file. So, I did a little research and found out this alternative answer which worked great.

      "To solve this problem,
      in mysql's configuration file (my.cnf), under [mysqld], add
      set-variable = max_allowed_packet=12M"

      Found at http://www.websina.com/bugzero/faq/exception-mysql-packet.html



      Again, thank you for the help, it got me going in the right direction.

      Nuguru

      Comment


      • #4
        It would appear that Colin's answer is for a Windows server and looking at the filename you found and altered you are running a Linux server.

        So it was sort of right, just wrong OS. If anyone has this problem on a Windows server, see Colin's answer instead of Nuguru.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X