Announcement

Collapse
No announcement yet.

attachments problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • attachments problem

    Hi ..

    i have a problem .. i can`t upload files to my forum using the attachment .. every time i try to upload this message appear ( Warning: fopen(): SAFE MODE Restriction in effect. The script whose uid is 32115 is not allowed to access /home/*****/public_html/***/2 owned by uid 99 in /includes/class_dm_attachment.php on line 555

    Warning: fopen(/home/****/public_html/***/2/4125.attach): failed to open stream: No such file or directory in /includes/class_dm_attachment.php on line 555 )

    this happend after the hosting server turned the safe mode on after i finished transfering my files to the files and folders system not on the database ..

    any help please ..

    thanks .

  • #2
    You can enable safe mode uploads and set a temp directory in your:

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options

    Comment


    • #3
      Warning: move_uploaded_file(): SAFE MODE Restriction in effect. The script whose uid is 32115 is not allowed to access /tmp owned by uid 0 in /includes/class_upload.php on line 333

      the mode for the tmp folder is 777



      when i turn the safe mode off this appear when upload a file
      ( alking1.jpg:
      Could not create file system directory to hold your attachment. )
      Last edited by aseer; Tue 8 Aug '06, 4:08pm.

      Comment


      • #4
        You cannot store attachments in the file system when running safe mode or open_basedir restrictions. You are limited to storing these in the database.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          ok Steve .. how can i get back to using the attachment on database ?

          Comment


          • #6
            You set this here:

            Admin CP -> Attachments -> Attachment Storage Type
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Hi Steve ..

              When i got back to database i lost my attachment ..

              any help please ?

              Comment


              • #8
                I'm afraid that the only thing I can recommend is that you restore a copy of the database from prior to attempting the attachment storgae change. Sorry!
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  is it possible to restore the back-up of the attachment table only without any problem ?

                  Comment


                  • #10
                    Without a problem? No. This is not likely to work. However you can certainly try it. I would strongly recommend making a fresh backup of the current database just in case.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    Loading...
                    Working...
                    X