No announcement yet.

Moved forums to a new server, everything works except the index

  • Filter
  • Time
  • Show
Clear All
new posts

  • Moved forums to a new server, everything works except the index

    There's another thread on this where I originally asked how to do a backup/restore then it turned into a troubleshooting thread. I figured I'd post it here so that I can get help quicker.

    I'm switching webhosts and I got the forums moved. It was working fine but now when I try to view the forums, the index.php file isn't functioning. I can view memberlist.php, I can log into the ACP. I can even make posts and send PMs.

    I just can't view the index. I've tried deleting all of my files and re-uploading them.

    I tried uploading a fresh index.php from the vBulletin installation package. No dice with either one.

    Here's how I backed up and restored my forums:
    Uploaded all of forum files from old host to new host - changed config.php to match new database.

    Performed a database backup from phpmyadmin as per the instructions here:

    Uploaded the .sql file as well as bigdump.php and used bigdump.php to restore the database.

    Went to forum index, everything worked great. I could view profiles, posts, topics, forum index.

    Then I made a new post, the post went through but then index.php stopped working. It won't load the forum index now.

    I dont know what else to try. I uploaded all of the exact same files that are on my other webserver. They work fine on the other webserver but not the new one.

    If nobody has any suggestions soon, I'm probably going to bite the bullet and create a new install of vBulletin then restore my backup onto the new installation and re-install all of my MODs.

  • #2
    Make sure the hook system is disabled, that you're using the default 3.5.4 style and if you have't upgraded to 3.5.4 yet I recommend to do this too.

    The index.php has to be from the same server.

    Also check if you don't have .htaccess that's trying to do tricks.

    And you could also check if there isn't already another index.html in the same dir for example.

    You could upload tools.php to the admincp and run it and re-import the styles and languages, rebuild bitfields, etc. and see if that works reset something that is required to make it work again.


    • #3
      Well, thanks for the response but I got tired of waiting so I made a fresh install on another directory then restored the database onto that install.

      So far, we're good. I can log in and view the index. I was planning on just redoing all of my hacks then everything should work properly?

      Or would it be better if I uploaded my old vBulletin files now and did what you suggested? Hopefully I'll get a response before I get impatient and go ahead with whatever direction I think is best.

      Edit: OK, I decided to delete all files and re-upload my old ones. Used tools.php to reset cookie path, imported latest style and language (was already up to date) and updated bitfield cache. Then I logged into ACP and turned hook system off.

      I am running 3.5.4. I'm going to update counters just to be sure then see what happens.

      When can I turn hooks back on?

      Edit 2: OK, now something weird happens when I try to update counters. When I do users, it skips then updates from 8000+ and that's it. Doesn't seem to do the other 4,000 (they're numbered from 1 to 4137-8000 due to an import glitch, this shouldn't affect anything though?).

      It does the same thing with threads - skips and updates 6000+ and that's it.

      Edit 3: Despite that, everything seems to work normally UNTIL I switch on the hook system and the index goes fubar. I'll try uninstalling this plugin that I think is the culprit and see what happens.

      Edit 4: Apparently it was the hook that I suspected, seems to be working fine. I'll try reinstalling the plugin. Thanks for the help Florin.
      Last edited by zeroality; Wed 2 Aug '06, 1:50pm.


      • #4
        Glad I could help - and good luck updating the plugin.


        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.