Announcement

Collapse
No announcement yet.

Embedding .wmv files and player

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • USAPatriot
    replied
    Hi,

    Sorry for the very late reply. Other issues came up that I had to address.
    I'm still not getting this to work in Netscape and with the newest change it's no longer working in IE either. The window shows but the video itself won't run. As a test I made it easy on myself and just tossed a youtube video link in there as an embed, but no luck. Oh...I'm now on V 3.6.2 ... -Rod-

    Leave a comment:


  • Andy Huang
    replied
    My appologies about the delay, had to go for supper with family and just got back now.

    I think the problem is that netscape doesn't support things from ground up, and needs to use 'plug-in' for the embed to play properly. And the x-ms-wmv might be causing confusion to the browser. Can you please try to change the "x-ms-wmv" part to "application/x-mplayer2" and see if that works? If all else fails, please try to incorporate the above with the <embed> version of the code offered on this page and see if it works.

    Leave a comment:


  • USAPatriot
    replied
    Here's the thread, BTW...

    http://www.usapatriotsamerica.com/fo...6439#post16439

    Leave a comment:


  • USAPatriot
    replied
    Cool! That works. In IE. Is there a way to get it to work in Netscape as well? I tested for both. I've got NS 7.2 -Rod-

    Leave a comment:


  • Andy Huang
    replied
    Yes, my bad; it should've been param.
    The quotataion marks are suppose to be there.

    I did some more digging (embedding video isn't something I do on daily basis) and it turns out that IE6, 7, and Safari does not fully support it properly just yet, and needs some extra code. Here's the modified code (that I was told by a few tutorial sites) which should make it work for the above mentioned browsers.

    Code:
    <object type="video/x-ms-wmv" 
      data="{param}">
    <param name="src" 
      value="{param}" />
      <param name="controller" value="true" />
    </object>
    Please give it a try again (my appologies for all these hassle) and let me know again.

    Regards,

    Leave a comment:


  • USAPatriot
    replied
    It didn't work. All I get is a black line across the post where the vid should be. I did change what looks like a syntax problem from "Parm" to "Param". Are those quotes supposed to be in there? -Rod-

    Leave a comment:


  • USAPatriot
    replied
    I'll give that a try and let ya know, thanks... -Rod-

    Leave a comment:


  • Andy Huang
    replied
    You can try to achieve this by adding a new bbcode.

    Admin CP > Custom BB Codes > Add New BB Code
    Title: anything you want, this is for your reference
    Tag: embed
    Replacement:
    Code:
    <object type="video/x-ms-wmv" 
      data="{parm}">
      <param name="controller" value="true" />
    </object>
    Example: [embed]http://www.yourdomain.com/video.wmv[/embed]
    Use Option: No.


    To add a video to your post, simply:
    Code:
    [embed]http://www.yourdomain.com/video.wmv[/embed]
    You can, at your descretion, embed multiple video's in one post, and they can be controlled by the visitor (IE: they click play on their own). Please note that this, unlike flash movie players custom created by youtube or google video etc., will trigger the browser to load the video as soon as the page is loaded, and hence be bandwidth intensive if your videos are large.

    As far as cross borwser support, this will only work with browsers that supports the object tag (part of the w3c compliance requirements), so most major browsers should work with it.

    Hope the above is helpful to some extend

    Leave a comment:


  • USAPatriot
    replied
    Originally posted by Alfarin View Post
    My appologies, I did not know exactly what you wantted.

    Will you be using the attachment feature for this, or will you be uploading the file some where on your server before hand? Please note that if you are using attachment feature, there is may be preformance issues with large attachments due to database max_packet_size settings coinsiding with large video files.
    No, I'll just be uploading onto my site somewhere, not attaching it. I just need to know how to embed and play it from within a post. Thanks. -Rod-

    Leave a comment:


  • Andy Huang
    replied
    My appologies, I did not know exactly what you wantted.

    Will you be using the attachment feature for this, or will you be uploading the file some where on your server before hand? Please note that if you are using attachment feature, there is may be preformance issues with large attachments due to database max_packet_size settings coinsiding with large video files.

    Leave a comment:


  • USAPatriot
    replied
    Actually, that does not appear to do the job. That is intended to import items from listed-specific sites. I want to be able to post and play my own. -Rod-

    Leave a comment:


  • Andy Huang
    replied
    vBulletin.org have a hack called "Any Media" which will do what you want.

    Leave a comment:


  • USAPatriot
    started a topic Embedding .wmv files and player

    Embedding .wmv files and player

    Hi,

    Is there a way to embed a .wmv file and have in play in a post, rather like what we see on youtube.com? I would assume, but don't know for sure, that there would be a one-file per thread limitation. Regardless, can it be done.

    As an aside, I'm on V3.5.3. I have the 3.5.4 files but never upgraded for some reason. Now I notice that my AdminCP no longer says 3.5.4 is the newest version available and that 3.5.3 is the up to date version. Did something happen to 3.5.4 that should cause me never to do the upgrade? Thanks a bunch. -Rod-
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X