Announcement

Collapse
No announcement yet.

Error importing phpbb -- My Solution --

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error importing phpbb -- My Solution --

    I have seen plenty of posts with the same error being reported on starting the import using Impex. The canned response is your info in the Impconfig file is wrong

    Well that may be true but in my case here is what I found to be incorrect.

    Item 1
    Installing VBulletin and per the notes in the /includes/config.php stats
    // ****** DATABASE TYPE ******
    // This is the type of the database server on which your vBulletin database will be located.
    // Valid options are mysql and mysqli. Try to use mysqli if you are using PHP 5 and MySQL 4.1+
    $config['Database']['dbtype'] = 'mysql';
    Ok so my server fits this profile and I set my config to reflect mysqli make note of this

    Install of VB is perfect, I now move to the import util that now gives me an error after setting things up perfectly
    ImpEx Database errormysql error: Invalid SQL: SELECT title, data FROM vb_datastore WHERE title = 'ImpExSession'

    mysql error: No database selected

    mysql error number: 1046

    Date: Tuesday 04th 2006f July 2006 09:24:35 AM
    Database: <YOURData_Base>
    MySQL error: No database selected
    After reading through Almost every post I discovered this is a common issue and the canned responce is
    That error indicates that the data in your ImpExconfig.php file is incorrect.
    If you'd like to provide me with FTP login details I'd gladly doublecheck that information.
    Ok I understand this can and sometimes is the issue, but
    The solution I found and what I believe is the core of the problem is this:

    Item 2
    In the Manual for ImpEx and ImpExconfig.php file it says this:
    $impexconfig['target']['databasetype']Enter the type of database here, currently this can only be mysql
    Now remember MYSQLI There in is the issue

    Your VBulletin DataBase is using mysqli, Impex is only allowed MYSQL

    The Fix:
    Change your /includes/config.php to be mysql (If you are using mysqli)

    This is what worked for me

    Ya I bloviate

  • #2
    That worked perfectly...., was scratching my head all night wondering what the hell I did wrong and I knew I hadn't since I have done a lot of imports with no error... anyway looks like that's a bug with the Impex System guys..

    I was using it to import from vBulletin 3.5 to 3.6 and got the same error, I think this goes for all boards.. Anyway once I changed mysqli to mysql in the config.php everything worked perfectly.

    Thank You

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X