Announcement

Collapse
No announcement yet.

MySQL Error : The table 'attachment' is full

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL Error : The table 'attachment' is full

    I was getting a lot of the following MySQL errors:

    MySQL Error : The table 'attachment' is full
    Error Number : 1114
    Digging through the MySQL docs, this appears to be due to the default index of the attachment myisam table being 4 bytes (ie: 4Gig maximum data size).

    Following the directions in the MySQL docs for increasing the table capacity:
    http://dev.mysql.com/doc/refman/5.0/en/full-table.html

    ...I executed the following MySQL command on the attachment table:
    ALTER TABLE attachment MAX_ROWS=1000000000 AVG_ROW_LENGTH=142000;
    This now lets me post new attachments, but there seem to be some problems with old attachments and thumbnails. Also, the number of rows dropped from around 30K to around 20K, which I assumed was due to deleted attachments and a general table cleanup triggered by the resize.

    Is there something else that has to be done when increasing the allowed length of the attachment table?!? Have I screwed up the database completely? HELP!!!


  • #2
    Did you make a backup of this database prior to doing this? Unfortunately I don't know how to fix this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I have a recent (nightly) backup.

      I'm assuming from your reply that this is going to require a restore (or merge) of my backup?!?

      What is the proper procedure for increasing the attachment table size limit?

      Comment


      • #4
        I don't think you can increase the table size limit above 4 Gb.

        As for the backup, I suggest restoring it to a new database (not your existing one), then editing config.php to point to this db.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X