Announcement

Collapse
No announcement yet.

I keep getting this database error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I keep getting this database error

    Hi,

    Every since I switched to my new VPS hosting account about a week ago I've been getting errors like this:

    Database error in vBulletin :

    Cannot use database pbvidsco_newforum

    MySQL Error : Unknown database 'pbvidsco_newforum'
    Error Number : 1049
    Date : Wednesday, July 5th 2006 @ 01:49:56 PM
    Script : http://www.pbvids.com/forum/usercp.php
    Referrer :
    IP Address : ******
    Username :
    Classname : vb_database
    The config file is set fine because the forums work for me and everyone else.

    It's not just that one script page either as you can see in this one:

    Database error in vBulletin :

    Cannot use database pbvidsco_newforum

    MySQL Error : Unknown database 'pbvidsco_newforum'
    Error Number : 1049
    Date : Wednesday, July 5th 2006 @ 06:35:38 AM
    Script : http://www.pbvids.com/forum/member.p...ion=getinfo&u=
    Referrer :
    IP Address : ******
    Username :
    Classname : vb_database
    What is causing this? Could it be that I need to update counters? Which ones?

    Need some help


    Thanks,

    Kyle

  • #2
    What is the name of your vB database? Have you installed any hacks or plugins?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      The name of my database is pbvidsco_newforum

      I have a few hacks installed. VbSEO, Shoutbox, and PhotoPost (vBgallery) are probably the only major ones. Or at least those are the only ones that could have changed code.

      Comment


      • #4
        Note: We can't provide support here for forums running hacks and plugins.

        To troubleshoot this, remove any hacks and disable your plugins, then see if you still have this problem.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

        Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hello -

          Did you ever get this problem resolved. I also moved to a new host and am getting the same error msg. In our case the script trying to run was on our old server. Here is what we are receiving - apparently the cron.php script on our old server (woodenboat-ubb.com) is still somehow being activated by the code running on the new.

          MySQL Error : Unknown database 'wb_vbulletin'
          Error Number : 1049
          Date : Saturday, July 15th 2006 @ 09:34:28 AM
          Script : http://www.woodenboat-ubb.com/vbulle...p?&rand=445259
          Referrer : http://www.woodenboatvb.com/www/vbulletin/upload/
          IP Address : 66.243.205.34
          Username :
          Classname : vb_database

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X