Announcement

Collapse
No announcement yet.

Users not getting validation email?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Users not getting validation email?

    I just opened my forums, and my users are not receiving their emails. I set that -f thing to "yes", but they still are not.

  • #2
    Make sure you have a valid webmaster's email address in your Admin CP settings and that there is only one address. Then try the vB email functions again.

    If it still doesn't work, then this is either a server and/or mailbox issue. By default vB uses PHP's mail() function for all its email and uses the SMTP server specified in php.ini. If PHP and the mail server are configured correctly then email will work. You can view the details here: http:
    //us3.php.net/mail/

    You will need to view the mail logs on the server to see what happened to those emails that don't work. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.

    Another thing to keep in mind is that many ISPs and mail clients are putting in very aggressive spam filters. For instance, AOL will not accept emails from domains that do not have reverse DNS setup. It's possible these emails are being placed into a spam folder or are being filtered.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      The webmaster email may be the problem; I think I left it blank. Exactly where do I set it?

      Comment


      • #4
        Admin CP -> vBulletin Options -> Site Name / URL / Contact Details -> Webmaster's Email
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Nope, that wasn't it, it was filled in.
          I assure you though that it is not a spam filtration. Too large a percentage was effected for it to be that, many of who didn't have spam filters.

          One I get the logs from my host, what would I do then?

          Comment


          • #6
            You host will need to look at the logs to see what is happening to these emails. They are either generating errors, or not. If not, then the problem is on the user end.

            I guarantee that if the server is setup correctly, these emails are being sent to the server.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I'm not sure if this has anything to do with the problem, but in the phpinfo section of the admin cp, on the "sendmail_from" line, I found this: "sendmail_from no value no value"

              Comment


              • #8
                This depnds on the OS you are running. Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I've PMed you it under the subject "Forum URL".

                  Comment


                  • #10
                    For future reference please do not PM me unless I request it.

                    You are on a Windows server. This means that your host needs to set up php.ini with a valid 'sendmail_from' address for PHP email to work.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Sorry, I'll remeber that for next time

                      As for my host, is there any way I can do this on a shared server. If not, what exactly should I email them?

                      EDIT:
                      One other question, is there any reason that VB has such a hard time with this? I never had this problem when I was using phpbb.

                      Comment


                      • #12
                        Now this is odd, I just received three emails from the forum.

                        The first one-
                        Subject: Action Required to Activate Membership for MFZ Forums
                        body:
                        ear Zack,
                        Thank you for registering at the MFZ Forums. Before we can activate your account one last step must be taken to complete your registration.
                        Please note - you must complete this last step to become a registered member. You will only need to visit this url once to activate your account.
                        To complete your registration, please visit this url:

                        (link removed)
                        **** Does The Above URL Not Work? ****
                        If the above url does not work, please use your Web browser to go to: (lin removed)
                        Please be sure not to add extra spaces. You will need to type in your username and activation number on the page that appears when you visit the url.
                        Your Username is: Zack
                        Your Activation ID is: ******
                        If you are still having problems signing up please contact a member of our support staff at ******@themysticalforestzone.com
                        All the best,
                        MFZ Forums
                        The next two were indentical body-wise:

                        Subject: vBulletin Email Test (With -f Parameter)
                        Body:
                        You are receiving this email because your email address was entered as an email test at MFZ Forums.
                        The first step of this email test script has been completed. However, a formatting test is still necessary:
                        A paragraph break.
                        A single line break.
                        Another paragraph break.
                        Another single line break.
                        Another single line break.
                        If the above lines look correct, you are finished. The email features on your server are setup correctly. If this email is run together on one line, there is possibly a configuration error with your mail server. Please ensure it is configured correctly.
                        The other email's subject was simply "Subject: vBulletin Email Test".

                        I tried testing this yesterday, but never received anything. These emails came at 5:11, 5:13, and 5:17. What's going on here?

                        EDIT: even stranger, I just tried testing the email in diagnostics, and received nothing...
                        Last edited by Zelos; Sun 25 Jun '06, 1:44pm.

                        Comment


                        • #13
                          This is an indication the vB is sending these emails. So the problem is either on the server or being blocked on the ISP/mailbox end.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Do you think this has something to with the fact that I enabled "phpinfo"?

                            Also, are there any security risks with keeping it enabled?

                            Comment


                            • #15
                              This has nothing to do with that at all.

                              You can disable it if you want. There's no need to keep it enabled all the time.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X