Announcement

Collapse
No announcement yet.

upgrade from 2.3.9 to 3.5.4 help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • upgrade from 2.3.9 to 3.5.4 help

    Well I followed letter by letter the Eva2000 upgrade triks.
    I made a fresh database where I restored my backup, I upped all the 3.54 files on a new folder, I pointed the config.php to the new database... after I run the command: mysite.xxx/vbb/install/upgrade.php.
    The browser ask for my customer nuber, I insert it and what I got is that the script is for 3.00b version..
    What I made of wrong?
    May I need other upgrades scripts not included in 3.5.4 to upgrade my 2.3.9 database?
    Thanks

  • #2
    That's correct, it will run through all the versions. Simply click Continue and follow the instructions/steps.
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      When I click continue I got:
      Code:
      Database error in vBulletin :
      Invalid SQL:
      ALTER TABLE calendarcustomfield
        ADD description MEDIUMTEXT;
      MySQL Error  : Table 'oldone.calendarcustomfield' doesn't exist
      Error Number : 1146
      Date         : Monday, May 29th 2006 @ 04:39:28 AM

      Comment


      • #4
        Try reverting the database to the original format, and then going through the upgrade again.
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Thanks Colin for your quick reply
          I' using a clean 2.3.9 install the only table I restored from backup (because are the only I really need) are:

          attachement
          forum
          forumpermission
          moderator
          post
          setting
          settingroup
          thread
          user
          useractivation
          userfield
          usergroup
          usertitle

          I never altered or restored other tables....

          Comment


          • #6
            You need to restore all the tables. While it may seem that you don't need them, they are actually used in the backend of the vBulletin script somewhere.
            Best Regards
            Colin Frei

            Please don't contact me per PM.

            Comment


            • #7
              Sorry Colin, but all the tables are there.. What I told in my previous post is that I restored only that data in the existing tables, vbb 2.3.9 is current running with that tables...
              Another thing.. could explay me how can 3.5.4 alter a table that 2.3.9 don't have installed?
              Last edited by pentium; Mon 29 May '06, 3:30am.

              Comment


              • #8
                Which script is producing that error? It looks like you have skipped at least one or more upgrade scripts.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  the script is upgrade_300b4.php, (I start launching the script upgrade.php).

                  Comment


                  • #10
                    Try running this script first: upgrade_300b3.php
                    Best Regards
                    Colin Frei

                    Please don't contact me per PM.

                    Comment


                    • #11
                      A big thanks to Colin & Steve, finally all is gone right
                      Just a thing.. in the last days I searched on this forum for posts about upgrades from 2.x to 3.5.4, and all the answers points to launch the script "upgrade.php" no one to the right "upgrade_300b3.php" that is perhaps included in the array of the "upgrade.php"...... is a bug of the main upgrade script or a missed tip of the upgrade instructions?

                      Comment


                      • #12
                        It should usually automatically jump to that script, and I've done quite a few upgrades from 2.x without ever having problems.

                        Most likely this was an inexplicable glitch in the matrix...
                        Best Regards
                        Colin Frei

                        Please don't contact me per PM.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X