Announcement

Collapse
No announcement yet.

Having trouble uploading attachments.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having trouble uploading attachments.

    This is a new install, converted from Ubbt, has been up since Friday morning.
    When I try to upload an attachment file over approx 8k the Manage Attachments window displays "Uploading File(s) Please Wait, then goes to a blank window with Done at the bottom. No error messages the file is not uploaded.
    Smaller files work ok.
    The files are uploading to a directory not the database.
    I tried a 28k file in the Upload Diagnostics with no errors.

    file_uploads: On
    open_basedir: None
    safe_mode: Off
    upload_tmp_dir: None
    upload_max_filesize: 2.00 MB
    Help Results
    No errors occurred while opening the uploaded file for reading.

    Only plugin is loading a couple of html files in global_start

    forum is at www.isgb.org/forum

    Thanks,
    Greg Fuchs
    Last edited by gfuchs; Sat 27 May '06, 6:00pm.

  • #2
    To troubleshoot this, remove any hacks and disable your plugins, then see if you still have this problem.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

    Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Atachment problem

      Disabled plugins, created the default style. No difference.
      Problem occurs with IE and Firefox btw.

      Uploaded original vB files to new test directory.
      Pointed to pre-conversion DB.
      Same problem.

      Tried from two different systems, same.

      Greg
      Last edited by gfuchs; Sun 28 May '06, 2:02pm.

      Comment


      • #4
        This is most likely a server issue then. The next step is to ask your host to create a tmp directory that is chmod'd to 777, then edit the php.ini file to set upload_tmp_dir to that directory. They will need to restart Apache after making that change, and you'll know if they did this by rerunning the attachment diagnostics and looking for the upload_tmp_dir info.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Uploading Attachments

          No change.
          There wasn't a php.ini, the hosting company created one for me.

          Created the directory & restarted.

          drwxrwxrwx 2 root root 4096 May 29 10:26 phptemp/

          file_uploads: On
          open_basedir: None
          safe_mode: Off
          upload_tmp_dir: /usr/local/phptemp
          upload_max_filesize: 2.00 MB

          Help Results
          No errors occurred while opening the uploaded file for reading.


          I really appreciate the help, especially on a holiday weekend.

          Greg

          Comment


          • #6
            If you have not installed any plugins or hacks (which includes portals), fill out a support ticket
            at:

            http://members.vbulletin.com/members...ontactform.php

            Be sure to include the login info to your Admin CP, phpMyAdmin and FTP. Please also include a complete description of the problem.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Problem uploading attachments

              Opened ticket.

              " Please also include a complete description of the problem."
              You mean "Doesn't work" is not enough of a description ?

              Thanks again,
              Greg

              Comment

              Loading...
              Working...
              X