Announcement

Collapse
No announcement yet.

Unable to add cookier. header already sent ERROR Please help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to add cookier. header already sent ERROR Please help

    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /includes/init.php on line 276


    Unable to add cookies, header already sent.
    File: /home/wshh/public_html/forums/includes/class_core.php
    Line: 2984


    How can i fix this. i get that when going to my admincp/index.php


    So i checked my class_core.php file and went down to 2984 and it said this

    echo "<br /><strong>Warning</strong>: $errstr in <strong>$errfile</strong> on line <strong>$errline</strong><br />";
    Last edited by hypnoticpimp; Fri 26 May '06, 9:37am.

  • #2
    The most common reason for this kind of error is an improperly edited config.php file. You need to open it and make sure there are no lines or spaces, even empty ones, before <?php or after ?>.

    I would suggest an editor such such as Textpad or UltraEdit that allows you to see empty spaces and lines.

    If that isn't the issue please disable any plugins and re-upload all non-image files except install/install.php in ASCII format.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      hey. when i added that disable plugin code to my config, it worked. and then i re uploaded all files, , and i still get that error

      Comment


      • #4
        One of your plugins is causing the problems, we cannot provide support for custom addons.

        Comment


        • #5
          But even if i type in that disable plug code on my config, and i go to my forums home at the top it doesnt even say "Welcome, $username$"
          at the top, its just empty.

          Comment


          • #6
            I'd guess its from one of your plugins which contain custom code. We cannot provide support for third party code.

            Comment


            • #7
              Make sure your files are being uploaded in ASCII format.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment


              • #8
                so do you think i should just unistall all my plugins

                Comment


                • #9
                  Yes.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API

                  Comment


                  • #10
                    wayne tried that ascii mode and no luck

                    Comment


                    • #11
                      Open a support ticket with FTP and AdminCP information. Ask for me and I will look at it.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud demonstration site.
                      vBulletin 5 API

                      Comment


                      • #12
                        so should i unstill all my plugins 1st or ask you for a upport ticket

                        Comment


                        • #13
                          If the problem occurs with all plugins disabled, then open a support ticket. If it doesn't then you will need to find the culprit plugin (by enabling them one at a time) and contact the author of that plugin for support.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API

                          Comment


                          • #14
                            when i disable the plugins using the disable plugins on config.php
                            I can access the admin panel with no errors. but when i go to my index.php i still see that at the top it doesnt even say "Welcome, $username$"
                            at the top, its just empty and now i had a gallery at the bottom of forum and thats gone as well. Just weird


                            So going from what i just said above, do you think i should uninstall all my plugins first, cause i have about 55 hacks installed on my forum. and if i still get errors. contact support. or should i dont uninstall no plugins yet, and just contact support and see if they can fix this?

                            Comment


                            • #15
                              We cannot provide support for forums running hacks.

                              To troubleshoot this, remove any hacks and disable your plugins, then see if you still have this problem.

                              Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                              define('DISABLE_HOOKS', true);

                              If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

                              Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              Loading...
                              Working...
                              X