Announcement

Collapse
No announcement yet.

Firefox users not able to see posts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • balkadmin
    replied
    I found out what it was. I always knew that anything related to Netscape was worthless, and this just confirmed me. As you can see in the code there are two very long comment tags like this <!-- -------- -->. Apparently Netscape didn't like them and considered anything between them as comments... That's why the posts didn't show up.

    Worthless piece of... program.

    Leave a comment:


  • Colin F
    replied
    The code I linked is also run, it's simply not directly on the page.
    I don't know of a setting that would cause this.

    Leave a comment:


  • balkadmin
    replied
    Simple and small i meant the one that is put on the page. Well anyway the site displays ok with all except Netscape browsers. But then again some can see it (as said in a post above) and some not.

    Could it be some setting?

    Leave a comment:


  • Colin F
    replied
    Simple and small?
    It includes all this: http://pagead2.googlesyndication.com/pagead/show_ads.js

    It's possible that one browser interprets the code differently than another one, but in the end it's still that code which is causing the problem.

    Leave a comment:


  • balkadmin
    replied
    Hm, could it be a problem with anything Netscape? This is just AdSense's javascript code which is simple and small, i don't think it is causing any problems. There are others who have placed it in the same place with me and i never saw anyone noticing this thing.

    Where do you think i could find some help?

    Leave a comment:


  • Colin F
    replied
    It's still a problem with JavaScript, I don't know how to fix this.

    Leave a comment:


  • balkadmin
    replied
    Sorry, i put it in PHP tags earlier not HTML so it seemed like there was something wrong. Try checking it now.

    Leave a comment:


  • Colin F
    replied
    I assume the JavaScript is disrupting the page somehow, but I don't know what to do against that, sorry.

    Leave a comment:


  • balkadmin
    replied
    showthread is the default. i haven't changed it

    postbit:
    HTML Code:
    <if condition="$post['islastshown']">
    
    $spacer_open
    <div style="padding:0px 0px $stylevar[cellpadding]px 0px">
    
    <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
    <tr>
    <td class="thead" align="left">Sponsored Links</td>
    </tr>
    <tr>
    <td class="alt1" align="center">
    <script type="text/javascript"><!--
    google_ad_client = "pub-7839004826939174";
    google_ad_width = 728;
    google_ad_height = 90;
    google_ad_format = "728x90_as";
    google_ad_type = "text_image";
    google_ad_channel ="";
    google_color_border = "F5F5FF";
    google_color_bg = "F5F5FF";
    google_color_link = "003366";
    google_color_url = "6C82B5";
    google_color_text = "000000";
    //--></script>
    <script type="text/javascript"
      src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
    </script>
    </td>
    </tr>
    </table>
    
    </div>
    $spacer_close
    
    </if>
    
    <!-- -------------------------------------------------------------------------------------------------------------- -->
    
    <!-- post #$post[postid] -->
    <if condition="$show['spacer']">
    	$spacer_open
    	<div id="edit$post[postid]" style="padding:0px 0px $stylevar[cellpadding]px 0px">
    	<if condition="!$post['islastshown']"><!-- this is not the last post shown on the page --></if>	
    </if>
    
    
    <table class="tborder" id="post$post[postid]" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
    <tr>
    	<td class="thead" $post[scrolltothis]>
    		<div class="normal" style="float:$stylevar[right]">
    			&nbsp;
    			<if condition="$show['postcount']">#<a href="showpost.php?$session[sessionurl]p=$post[postid]&amp;postcount=$post[postcount]" target="new" rel="nofollow" id="postcount$post[postid]" name="$post[postcount]"><strong>$post[postcount]</strong></a> &nbsp;</if>
    			<if condition="$show['reputationlink']"><a href="reputation.php?$session[sessionurl]p=$post[postid]" rel="nofollow"><img class="inlineimg" src="$stylevar[imgdir_button]/reputation.gif" alt="<phrase 1="$post[username]">$vbphrase[add_to_xs_reputation]</phrase>" border="0" /></a> &nbsp;</if>
    			<if condition="$show['reportlink']"><a href="report.php?$session[sessionurl]p=$post[postid]" rel="nofollow"><img class="inlineimg" src="$stylevar[imgdir_button]/report.gif" alt="$vbphrase[report_bad_post]" border="0" /></a> &nbsp;</if>
    			$post[iplogged]
    			<if condition="$show['inlinemod']">
    			<input type="checkbox" name="plist[$postid]" id="plist_$postid" style="vertical-align:middle; padding:0px; margin:0px 0px 0px 5px" value="$post[checkbox_value]" onclick="inlineMod.toggle(this)" />
    			</if>
    		</div>
    		
    		<div class="normal">
    			<!-- status icon and date -->
    			<a name="post$post[postid]"><img class="inlineimg" src="$stylevar[imgdir_statusicon]/post_$post[statusicon].gif" alt="$post[statustitle]" border="0" /></a>
    			<if condition="!$show['announcement']">
    				$post[postdate]<if condition="!$show['detailedtime']">, $post[posttime]</if>
    			<else />
    				<phrase 1="$post[startdate]" 2="$post[enddate]">$vbphrase[x_until_y]</phrase>
    			</if>
    			$post[firstnewinsert]
    			<!-- / status icon and date -->
    		</div>
    	</td>
    </tr>
    <tr>
    	<td class="alt2" style="padding:0px">
    		<!-- user info -->
    		<table cellpadding="0" cellspacing="$stylevar[cellpadding]" border="0" width="100%">
    		<tr>
    			<if condition="$show['avatar']"><td class="alt2"><a href="member.php?$session[sessionurl]u=$post[userid]"><img src="$post[avatarurl]" $post[avwidth] $post[avheight] alt="<phrase 1="$post[username]">$vbphrase[xs_avatar]</phrase>" border="0" /></a></td></if>
    			<td nowrap="nowrap">
    			
    				<div id="postmenu_$post[postid]">
    					<if condition="$show['profile']">
    					<a class="bigusername" href="member.php?$session[sessionurl]u=$post[userid]">$post[musername]</a>
    					$post[onlinestatus]
    					<script type="text/javascript"> vbmenu_register("postmenu_$post[postid]", true); </script>
    					<else />
    					$post[musername]
    					</if>
    				</div>
    				
    				<if condition="$post['usertitle']"><div class="smallfont">$post[usertitle]</div></if>
    				<if condition="$post['rank']"><div class="smallfont">$post[rank]</div></if>
    				
    			</td>
    			<td width="100%">&nbsp;</td>
    			<td valign="top" nowrap="nowrap">
    				
    				<div class="smallfont">
    					<if condition="$post['joindate']"><div>$vbphrase[join_date]: $post[joindate]</div></if>
    					<if condition="$post['field2']"><div>$vbphrase[location_perm]: $post[field2]</div></if>
    					<if condition="$post['age']"><div>$vbphrase[age]: $post[age]</div></if>
    					<div>
    						$vbphrase[posts]: $post[posts]
    					</div>
    					<if condition="$show['reputation']"><if condition="$show['reppower']">$vbphrase[reppower]: $post[reppower] </if><div>$post[reputationdisplay]</div></if>
    					<div>$post[icqicon] $post[aimicon] $post[msnicon] $post[yahooicon] $post[skypeicon]</div>
    				</div>
    				
    			</td>
    		</tr>
    		</table>
    		<!-- / user info -->
    	</td>
    </tr>
    <tr>
    	<td class="alt1" id="td_post_$post[postid]">
    	<!-- message, attachments, sig -->
    	
    		<if condition="$show['messageicon'] OR $post['title']">
    			<!-- icon and title -->
    			<div class="smallfont">
    				<if condition="$show['messageicon']"><img class="inlineimg" src="$post[iconpath]" alt="$post[icontitle]" border="0" /></if>
    				<if condition="$post['title']"><strong>$post[title]</strong></if>
    			</div>
    			<hr size="1" style="color:$stylevar[tborder_bgcolor]" />
    			<!-- / icon and title -->
    		</if>
    		
    		<!-- message -->
    		<div id="post_message_$post[postid]">$post[message]</div>
    		<!-- / message -->
    	
    		<if condition="$show['attachments']">
    		<!-- attachments -->
    			<div style="padding:$stylevar[cellpadding]px">
    			
    			<if condition="$show['thumbnailattachment']">
    				<fieldset class="fieldset">
    					<legend>$vbphrase[attached_thumbnails]</legend>
    					<div style="padding:$stylevar[formspacer]px">
    					$post[thumbnailattachments]
    					</div>
    				</fieldset>
    			</if>
    		
    			<if condition="$show['imageattachment']">
    				<fieldset class="fieldset">
    					<legend>$vbphrase[attached_images]</legend>
    					<div style="padding:$stylevar[formspacer]px">
    					$post[imageattachments]
    					</div>
    				</fieldset>
    			</if>
    			
    			<if condition="$show['imageattachmentlink']">
    				<fieldset class="fieldset">
    					<legend>$vbphrase[attached_images]</legend>
    					<table cellpadding="0" cellspacing="$stylevar[formspacer]" border="0">
    					$post[imageattachmentlinks]
    					</table>
    					</fieldset>
    			</if>
    			
    			<if condition="$show['otherattachment']">
    				<fieldset class="fieldset">
    					<legend>$vbphrase[attached_files]</legend>
    					<table cellpadding="0" cellspacing="$stylevar[formspacer]" border="0">
    					$post[otherattachments]
    					</table>
    				</fieldset>
    			</if>
    			
    			<if condition="$show['moderatedattachment']">
    				<fieldset class="fieldset">
    					<legend>$vbphrase[attachments_pending_approval]</legend>
    					<table cellpadding="0" cellspacing="$stylevar[formspacer]" border="0">
    					$post[moderatedattachments]
    					</table>
    				</fieldset>		
    			</if>
    			
    			</div>
    		<!-- / attachments -->
    		</if>
    		
    		<if condition="$post['signature']">
    		<!-- sig -->
    			<div>
    				__________________<br />
    				$post[signature]
    			</div>
    		<!-- / sig -->
    		</if>
    		
    		<if condition="$show['postedited']">
    		<!-- edit note -->
    			<div class="smallfont">			<hr size="1" style="color:$stylevar[tborder_bgcolor]" />
    				<em>
    				<phrase 1="$post[edit_username]" 2="$post[edit_date]" 3="$post[edit_time]">$vbphrase[last_edited_by_x_on_y_at_z]</phrase>.
    				<if condition="$post['edit_reason']">$vbphrase[reason]: $post[edit_reason]</if>
    				</em>
    			</div>
    		<!-- / edit note -->
    		</if>
    	
    		<div align="$stylevar[right]">
    			<!-- controls -->
    			<if condition="$post['editlink']">
    				<a href="$post[editlink]" name="vB::QuickEdit::$post[postid]"><img src="$stylevar[imgdir_button]/edit.gif" alt="$vbphrase[edit_delete_message]" border="0" /></a>
    			</if>
    			<if condition="$post['forwardlink']">
    				<a href="$post[forwardlink]"><img src="$stylevar[imgdir_button]/forward.gif" alt="$vbphrase[forward_message]" border="0" /></a>
    			</if>
    			<if condition="$post['replylink']">
    				<a href="$post[replylink]" rel="nofollow"><img src="$stylevar[imgdir_button]/<if condition="$post['forwardlink']">reply_small<else />quote</if>.gif" alt="$vbphrase[reply_with_quote]" border="0" /></a>
    			</if>
    			<if condition="$show['quickreply'] AND !$show['threadedmode']">
    				<a href="$post[replylink]" rel="nofollow" id="qr_$post[postid]" onclick="return false"><img src="$stylevar[imgdir_button]/quickreply.gif" alt="$vbphrase[quick_reply_to_this_message]" border="0" /></a>
    			</if>
    			<if condition="$show['moderated']">
    				<img src="$stylevar[imgdir_misc]/moderated.gif" alt="$vbphrase[moderated_post]" border="0" />
    			</if>
    			<!-- / controls -->
    		</div>
    		
    	<!-- message, attachments, sig -->
    	
    	</td>
    </tr>
    </table>
    
    <!-- post $post[postid] popup menu -->
    <div class="vbmenu_popup" id="postmenu_$post[postid]_menu" style="display:none">
    	<table cellpadding="4" cellspacing="1" border="0">
    	<tr>
    		<td class="thead">$post[username]</td>
    	</tr>
    	<if condition="$show['profile']">
    		<tr><td class="vbmenu_option"><a href="member.php?$session[sessionurl]u=$post[userid]">$vbphrase[view_public_profile]</a></td></tr>
    	</if>
    	<if condition="$show['pmlink']">
    		<tr><td class="vbmenu_option"><a href="private.php?$session[sessionurl]do=newpm&amp;u=$post[userid]" rel="nofollow"><phrase 1="$post[username]">$vbphrase[send_private_message_to_x]</phrase></a></td></tr>
    	</if>
    	<if condition="$show['emaillink']">
    		<tr><td class="vbmenu_option"><a href="sendmessage.php?$session[sessionurl]do=mailmember&amp;u=$post[userid]" rel="nofollow"><phrase 1="$post[username]">$vbphrase[send_email_to_x]</phrase></a></td></tr>
    	</if>
    	<if condition="$show['homepage']">
    		<tr><td class="vbmenu_option"><a href="$post[homepage]"><phrase 1="$post[username]">$vbphrase[visit_xs_homepage]</phrase></a></td></tr>
    	</if>
    	<if condition="$show['search']">
    		<tr><td class="vbmenu_option"><a href="search.php?$session[sessionurl]do=finduser&amp;u=$post[userid]" rel="nofollow"><phrase 1="$post[username]">$vbphrase[find_all_posts_by_x]</phrase></a></td></tr>
    	</if>
    	<if condition="$post['userid'] AND $show['member']">
    	<tr><td class="vbmenu_option"><a href="profile.php?$session[sessionurl]do=addlist&amp;userlist=buddy&amp;u=$post[userid]"><phrase 1="$post[username]">$vbphrase[add_x_to_buddy_list]</phrase></a></td></tr>
    	</if>
    	</table>
    </div>
    <!-- / post $post[postid] popup menu -->
    
    
    
    
    <if condition="$show['spacer']">
    	</div>
    	$spacer_close
    </if>
    <!-- / post #$post[postid] -->
    
    <!-- -------------------------------------------------------------------------------------------------------------- -->
    
    <if condition="$post[postcount] % $vboptions[maxposts] == 1">
    
    $spacer_open
    <div style="padding:0px 0px $stylevar[cellpadding]px 0px">
    
    <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
    <tr>
    <td class="thead" align="left">Sponsored Links</td>
    </tr>
    <tr>
    <td class="alt1" align="center">
    <script type="text/javascript"><!--
    google_ad_client = "pub-7839004826939174";
    google_ad_width = 728;
    google_ad_height = 90;
    google_ad_format = "728x90_as";
    google_ad_type = "text_image";
    google_ad_channel ="";
    google_color_border = "F5F5FF";
    google_color_bg = "F5F5FF";
    google_color_link = "003366";
    google_color_url = "6C82B5";
    google_color_text = "000000";
    //--></script>
    <script type="text/javascript"
      src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
    </script>
    </td>
    </tr>
    </table>
    
    </div>
    $spacer_close
    
    </if>
    Last edited by balkadmin; Sun 28 May '06, 6:54am.

    Leave a comment:


  • Colin F
    replied
    Can you post the contents of your SHOWTHREAD and postbit templates please.

    Leave a comment:


  • balkadmin
    replied
    Ok one weird thing that i just noticed. Using FF version 1.5.0.3 again, when i load the main page and then click directly on the the link for the last post in a thread, the posts appear just fine but the AdSense doesn't.

    When i click first on the forum link then on the thread link, the posts don't appear but the AdSense does...

    Edit: Just noticed that it doesn't happen always. For example clicking the link for last post in "Advertisements" will work but clicking the link for last post in "Greece" for example, won't work.
    Last edited by balkadmin; Sun 28 May '06, 5:53am.

    Leave a comment:


  • balkadmin
    replied
    Mozilla too. But they are practically the same anyway. What version are you using? The thing is that they didn't have a problem before.

    Could it be the switch to a new server? But that sounds a bit exaggerated.

    Leave a comment:


  • TeaTree
    replied
    Works fine for me-Sounds more like to be a problem with their ISP, seeing as I also use firefox and had no problem

    Do they only get the problem in firefox? Or any other browsers as well?

    Leave a comment:


  • balkadmin
    replied
    Any ideas?

    Leave a comment:


  • balkadmin
    replied
    Was everything working correctly on the old server?
    Yes it was working correctly i think. Well personally i don't use firefox but no one ever complained and there was a fair amount of firefox users judging by the site's stats.

    Did you revert the templates after upgrading?
    what do you mean?

    Any particular version of Firefox? I just loaded it in Firefox 1.5.03 (with no extensions) and the site loaded just fine.
    i used that too but i can't see the posts. everything else appears fine

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X