Announcement

Collapse
No announcement yet.

Getting rid of constant database errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting rid of constant database errors

    My board gets a lot of database errors. It has 1.25 million posts, and now up to 4,000 new posts per day.

    I think this has something to do with the search function. Every time I look up someones IP, the board goes down.

    Will enabling FULLTEXT help? Do you recommend I prune posts? If I do prune, will the post count remain the same? Etc. What would help take away these constant errors?

    Thanks.

  • #2
    First, we need to see the real error message. Right-click on the error page and go to View/Source. Then copy-n-paste the error message here.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      OK, let me just take my board down... done...

      HTML Code:
      <!--
      Database error in vBulletin :
      
      mysql_connect(): User myusername has already more than 'max_user_connections' active connections
      /home/myusername
      /public_html/board/includes/class_core.php on line 273
      
      MySQL Error  : 
      Error Number : 
      Date         : Thursday, May 11th 2006 @ 10:30:48 PM
      Script       : http://www.myurl.com/board/
      Referrer     : 
      IP Address   : xx.xx.x.xxx
      Username     : 
      Classname    : vb_database
      -->

      Comment


      • #4
        mysql_connect(): User myusername has already more than 'max_user_connections' active connections

        The server has maxed out the number of MySQL connections it allows your user to have. You can try turning persistent connections off in your config.php:

        PHP Code:
                //      ****** MASTER DATABASE PERSISTENT CONNECTIONS ******
                //      This option allows you to turn persistent connections to MySQL on or off.
                //      The difference in performance is negligible for all but the largest boards.
                //      If you are unsure what this should be, leave it off. (0 = off; 1 = on)
        $config['MasterServer']['usepconnect'] = 0
        But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          mysql_connect(): User myusername has already more than 'max_user_connections' active connections

          The server has maxed out the number of MySQL connections it allows your user to have. You can try turning persistent connections off in your config.php:

          PHP Code:
                  //      ****** MASTER DATABASE PERSISTENT CONNECTIONS ******
                  //      This option allows you to turn persistent connections to MySQL on or off.
                  //      The difference in performance is negligible for all but the largest boards.
                  //      If you are unsure what this should be, leave it off. (0 = off; 1 = on)
          $config['MasterServer']['usepconnect'] = 0
          But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.
          Darn it, persistent connections are already off. I'm on a dedicated, Red Hat. Where can I set max connections? I know my provider has upped it serveral times. (Don't worry, you don't have to go through the editing process, I just need to know where the file will probably be located.)

          Comment


          • #6
            Check your php.ini file for a max_user_connections setting.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X