Announcement

Collapse
No announcement yet.

Install fails looking for dB table

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install fails looking for dB table

    Hi folks, I'm hoping you can help me solve a problem I'm having with a vB install. When I go to the install.php url, I immediately get the following error before the script even loads:

    Code:
    Database error in vBulletin :
    
    Invalid SQL:
    
                SELECT title, data
                FROM datastore
                WHERE title IN ('','options','bitfields','forumcache','usergroupcache','stylecache','languagecache','products','pluginlist','cron');
    
    MySQL Error  : Table 'temp1_com_vb.datastore' doesn't exist
    Error Number : 1146
    Date         : Wednesday, May 10th 2006 @ 08:55:25 PM
    Script       : [URL="http://www.vicphysics.org/forumnew/install/install.php"]http://www.vicphysics.org/forumnew/install/install.php[/URL]
    Referrer     : 
    IP Address   : 210.49.222.176
    Username     : 
    Classname    : vb_database
    Here are the relevent parts of my config file:

    Code:
        //    ****** DATABASE NAME ******
        //    This is the name of the database where your vBulletin will be located.
        //    This must be created by your webhost.
    $config['Database']['dbname'] = 'temp1_com_vb';
    
        //    ****** TABLE PREFIX ******
        //    Prefix that your vBulletin tables have in the database.
    $config['Database']['tableprefix'] = '';
    
        //    ****** TECHNICAL EMAIL ADDRESS ******
        //    If any database errors occur, they will be emailed to the address specified here.
        //    Leave this blank to not send any emails when there is a database error.
    $config['Database']['technicalemail'] = [EMAIL="%[email protected]"]'[email protected][/EMAIL]';
    
        //    ****** FORCE EMPTY SQL MODE ******
        // New versions of MySQL (4.1+) have introduced some behaviors that are
        // incompatible with vBulletin. Setting this value to "true" disables those
        // behaviors. You only need to modify this value if vBulletin recommends it.
    $config['Database']['force_sql_mode'] = false;
    
    
    
        //    ****** MASTER DATABASE SERVER NAME AND PORT ******
        //    This is the hostname or IP address and port of the database server.
        //    If you are unsure of what to put here, leave the default values.
    $config['MasterServer']['servername'] = 'localhost';
    $config['MasterServer']['port'] = 3306;
    
        //    ****** MASTER DATABASE USERNAME & PASSWORD ******
        //    This is the username and password you use to access MySQL.
        //    These must be obtained through your webhost.
    $config['MasterServer']['username'] = 'aip';
    $config['MasterServer']['password'] = '*******';
    The database is a newly created one without any tables in it. I thought the install script was supposed to create the tables? Why is it looking for them before they're created?

    Obviously I'm not understanding something correctly. Your help would be grately appreciated!

    Thanks.
    Graviton City: the Project A-ko Web Site
    http://www.gravitoncity.com
    Anime Imagery
    http://au.groups.yahoo.com/group/animeimagery/

  • #2
    Try reuploading the vBulletin install and includes directory and see if it fixes the probl;em.

    Comment


    • #3
      Thanks for the suggestion. Just gave that a try, but it didn't seem to make any difference. Any other suggestions?
      Graviton City: the Project A-ko Web Site
      http://www.gravitoncity.com
      Anime Imagery
      http://au.groups.yahoo.com/group/animeimagery/

      Comment


      • #4
        The install file shouldn't be trying to read from the database yet :/

        Comment


        • #5
          That's what I thought, but the error always appears! Perhaps I should download vB again and try uploading from that? Maybe I got a corrupted file somehow?
          Graviton City: the Project A-ko Web Site
          http://www.gravitoncity.com
          Anime Imagery
          http://au.groups.yahoo.com/group/animeimagery/

          Comment


          • #6
            same problem

            I am having this exact same issue, did this ever get resolved? Please advise.

            Comment


            • #7
              seat as far as OI know it did. Try reuploading the defualt vBulletin files and see if the problem gets fixed.

              Comment


              • #8
                I just reuploaded the entire directory and get the same error.

                Comment


                • #9
                  some more info about my setup

                  I am hosting on a machine I run several other installs of vbulletin on, but in a separate database. I uploaded via winscp and changed permissions to the web server's user. Please help! I have no idea why it would be trying to read from a table instead of creating one, I have never had problems installing vbulletin before.

                  Comment


                  • #10
                    Remove one of the underscores from the db name and try again:

                    $config['Database']['dbname'] = 'temp1_com_vb';
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      That was Neil's config file. My dbname is
                      $config['Database']['dbname'] = 'seat10';


                      Let me know if you need my whole config file or the error.

                      Comment


                      • #12
                        You should start your own thread with all the relevant info.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X