Announcement

Collapse
No announcement yet.

Path issue with IIS & PHP4 - blank page displayed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    The white pages are due to one of these causes:

    1. You did not upload the vB files correctly. Reupload the vB non-image files and make sure you upload these in ASCII format and that you overwrite the ones on the server. Make sure you upload the Admin CP files to the admincp directory specified in your config.php file.

    2. You have extra space or lines in your config.php file. Make sure there is no whitespace or extra lines in config.php either before the <?php or after the ?>.

    3. You have a bad plugin installed. To disable the plugin system, edit config.php and add this line
    right under <?php

    define('DISABLE_HOOKS', true);

    4. Your PHP has magic_quotes_sybase turned on. You have to run this off. On *nix systems you can d
    o this by creating an .htaccess file with this content and placing it in your main forum directory:

    php_flag magic_quotes_sybase 0

    5. [For multiple white pages] You have added code to your header, headinclude or phpinclude templates that is no longer functional.
    [For white pages in a selct area] You have added code to one of your templates that is causing this problem.

    6. You have a corrupted template. Repairing the template table may help:

    REPAIR TABLE template;

    7. You have GZIP enabled. Try turning GZIP off here:

    Admin CP -> vBulletin Options -> Cookies and HTTP Header Options -> GZIP HTML Output -> No

    Sometimes this problem is caused when your server is already using GZIP and by turning this on in vB you were double compressing. This causes problems with some pages but not others. It also happens to some people and not others.

    Leave a comment:


  • handruin
    replied
    Thanks Steve,

    I just tried that and it unfortunately did not help. I still get a blank page. Is there any other config info I can provide that might help to determine the issue?

    Leave a comment:


  • Steve Machol
    replied
    Try using this setting in the config.php file:

    // ******** FULL PATH TO FORUMS DIRECTORY ******
    // On a few systems it may be necessary to input the full path to your forums directory
    // for vBulletin to function normally. You can ignore this setting unless vBulletin
    // tells you to fill this in. Do not include a trailing slash!
    // Example Unix:
    // $config['Misc']['forumpath'] = '/home/users/public_html/forums';
    // Example Win32:
    // $config['Misc']['forumpath'] = 'c:\program files\apache group\apache\htdocs\vb3';
    $config['Misc']['forumpath'] = '';

    Leave a comment:


  • handruin
    started a topic Path issue with IIS & PHP4 - blank page displayed

    Path issue with IIS & PHP4 - blank page displayed

    I'm moving a vbulletin website over to a new machine and I'm having the following problem...vbulletin won't render; all I get is a blank page.

    Config:
    Windows 2000 server
    IIS
    PHP 4.4.2
    MySQL 4.0.26
    unmodified install of vbulletin 3.5.4

    I believe I've boiled the issue down to one problem...the "require_once()" function is halting the execution due to pathing issues, but I don't know why.

    On my new host I have an IIS virtual directory set to a different drive "K:\mywebfolder" and php is configured to work with this. I verified this by running a "phpinfo()" call and the page renders perfect.

    So I did a small test as follows (I created a file named test.php before beginning):

    Directory structure:

    k:\webdirectory\
    ----------------index.php
    ----------------test.php

    This code works (index.php):
    <?php
    require_once('test.php');
    echo "this is a test";
    ?>

    This code does not work (index.php):
    <?php
    require_once('./test.php');
    echo "this is a test";
    ?>

    I verified that the vbulletin's index.php halts at the first require statement "require_once('./global.php');" ...this causes the script to halt even when I know the directory structure is correct. Is there some relation to using that style pathing with virtual directories that might cause a problem? The reason I think it's that combination is because the current IIS host where vbulletin is running doesn't have this problem and it is NOT using a virtual directory. My simple test also proves this is where my problem lives...but I don't know how to fix it (I've always used apache in the past, but can't for this project).

Related Topics

Collapse

  • sudbury8
    Site not working
    by sudbury8
    I have changed my URL on the VBulletin wedsite and spelled it wrong .I have corrected the spelling, but the site is still is not working.Just wondering if there is a license problem with my site,
    ...
    Thu 17 Nov '16, 5:55am
Working...
X