Announcement

Collapse
No announcement yet.

Too many connections error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Too many connections error

    I'm occasionally receiving an error message when trying to connect to my forums.


    Database error in vBulletin :

    mysql_connect(): Too many connections
    /mnt/web_j/d15/s33/b0277619/www/includes/class_core.php on line 279

    MySQL Error :
    Error Number :
    Date : Wednesday, May 3rd 2006 @ 04:49:11 PM

    Any idea on how to stop this?
    Last edited by Barnie; Thu 4 May '06, 11:32am.

  • #2
    As the error says, you have too many db connections. Are you using pconnect?

    includes/config.php

    Code:
    	//	****** MASTER DATABASE PERSISTENT CONNECTIONS ******
    	//	This option allows you to turn persistent connections to MySQL on or off.
    	//	The difference in performance is negligible for all but the largest boards.
    	//	If you are unsure what this should be, leave it off. (0 = off; 1 = on)
    $config['MasterServer']['usepconnect'] = 0;
    Make sure this is set to 0.

    If you continue to have the problem, then you need to ask your host to increase the connection limit for MySQL.

    Comment


    • #3
      It's set to 0. Perhaps I'll contact my host and see what the limit is set to. It's not a busy board though so I wouldn't think that would be an issue. Thanks for the help.

      http://www.edmontongolf.com
      http://www.golfingcalgary.com

      Comment


      • #4
        That error is for the entire server, not just your sites.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          My host has told me to turn on Persistent connections.
          My Football Forum

          Comment


          • #6
            Originally posted by boro_boy View Post
            My host has told me to turn on Persistent connections.
            That would make this problem worse.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X