Announcement

Collapse
No announcement yet.

3.07 > 3.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.07 > 3.5

    I haven't made the jump yet, but I'm very eager to. I've read that you should uninstall all the hacks before upgrading, I was just wondering if this is absolutely necessary. I have many hacks installed and actually don't remember all the hacks I have installed.

  • #2
    No its not 100% nessary, but it'd be a good idea if you could.

    Comment


    • #3
      I was reading eva's guide and had a quick question on step 5.

      5.
      create a new temp directory on your forum site and then upload latest upgrade vB php files in the downloaded vB zip file (upload folder contents) to this temp directory. Upload all the vBulletin files except the images/ folder and config.php.new to temp directory. Make sure you upload these files in ASCII format

      So I created the temp dir /forums2. Do I then upload the fresh vB3.5 files to the temp dir, then overwrite all those files (if they already exist) with the original vB files to my current forum?

      Comment


      • #4
        It's formulated funny.
        I'd simply upload all the default files, from the vBulletin zip file.
        You'll have to reedit the config.php though.
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Originally posted by Colin F
          It's formulated funny.
          I'd simply upload all the default files, from the vBulletin zip file.
          You'll have to reedit the config.php though.
          Here's what I've done so far.

          I created a new db and a temp dir. I imported a backup of my current forum into the new db. I uploaded a fresh 3.5 to the temp dir and edited the config to point to the new db. When I goto the tempdir I get this:

          vBulletin datastore error caused by one or more of the following:
          1. You may have uploaded vBulletin 3.5 files without also running the vBulletin 3.5 upgrade script. If you have not run the upgrade script, do so now.
          2. The datastore cache may have been corrupted. Run Rebuild Bitfields from tools.php, which you can upload from the do_not_upload folder of the vBulletin package.
          So by running the upgrade, should everything be fine?

          Comment


          • #6
            Yes. As the error message says in 1, you'll need to run the upgrade script for it to work.
            Best Regards
            Colin Frei

            Please don't contact me per PM.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X