Announcement

Collapse
No announcement yet.

Information on large uploads

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Information on large uploads

    This is driving me mad but here it is. I'm trying to upload files between 12-13MB in size and get a page cannot be displayed error after about 15 minutes.

    I've tried increasing all timeout's. Uploading sizes of 10.6MB and below work fine. Here are my PHP settings:

    max_execution_time 30
    max_input_time 60
    post_max_size 32M
    upload_max_filesize 32M
    memory_limit 32M

    These are the local values, the master one's are different.
    It use to work as we have big files on our board but not anymore the only thing i can think of that changed was upgrading from 3.5.1 to 3.5.3 but i know that the attachment program hasn't been changed.

    I do have hacks installed but none of them affect the attachment process and these hacks were installed previously when it use to work.

    Is there a default setting somewhere which restricts over 10MB that i am missing? Any suggestions would be good. Should i open a support ticket?

  • #2
    The 'max_execution_time' and 'max_input_time' variables are definitely too small for large file uploads.

    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X