Announcement

Collapse
No announcement yet.

Nifty new error message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nifty new error message

    I just started getting this "Database Error" email in the last hour or so. I have no idea what it means. If anyone could shed some light, I would greatly appreciate it.

    Thx

    Database error in vBulletin 3.5.2:
    Invalid SQL:
    INSERT INTO vb_template
    (styleid, templatetype, title, dateline, username, template)
    VALUES
    (1, 'css', '.alt1, .alt1Active', 1145827035, 'ninjapete', 'a:7:{s:10:\"background\";s:7:\"#e1e4ed\";s:5:\"color\";s:7:\"#000000\";s:4:\"font\";a:3:{ s:5:\"style\";s:0:\"\";s:4:\"size\";s:0:\"\";s:6:\"family\";s:0:\"\";}s:5:\"EXTRA\";s:0:\" \";s:6:\"LINK_N\";a:3:{s:10:\"background\";s:0:\"\";s:5:\"color\";s:0:\"\";s:15:\"text-decoration\";s:0:\"\";}s:6:\"LINK_V\";a:3:{s:10:\"background\";s:0:\"\";s:5:\"color\";s:0: \"\";s:15:\"text-decoration\";s:0:\"\";}s:6:\"LINK_M\";a:3:{s:10:\"background\";s:0:\"\";s:5:\"color\";s:0: \"\";s:15:\"text-decoration\";s:0:\"\";}}');
    MySQL Error : Duplicate entry '.alt1, .alt1Active-1' for key 2 Error Number : 1062
    Date : Sunday, April 23rd 2006 @ 05:17:15 PM

  • #2
    It would help if you provided the full error message. My guess is that you've installed a hack or plugin that's causing this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      that is the full error message..aside of the ip address and personal info at the bottom of the email...i assure you no hacks or plugins have been installed

      Comment


      • #4
        Here is the full message...


        Invalid SQL:
        INSERT INTO vb_template
        (styleid, templatetype, title, dateline, username, template)
        VALUES
        (1, 'css', '.alt1, .alt1Active', 1145827035, 'ninjapete', 'a:7:{s:10:\"background\";s:7:\"#e1e4ed\";s:5:\"color\";s:7:\"#000000\";s:4:\"font\";a:3:{ s:5:\"style\";s:0:\"\";s:4:\"size\";s:0:\"\";s:6:\"family\";s:0:\"\";}s:5:\"EXTRA\";s:0:\" \";s:6:\"LINK_N\";a:3:{s:10:\"background\";s:0:\"\";s:5:\"color\";s:0:\"\";s:15:\"text-decoration\";s:0:\"\";}s:6:\"LINK_V\";a:3:{s:10:\"background\";s:0:\"\";s:5:\"color\";s:0: \"\";s:15:\"text-decoration\";s:0:\"\";}s:6:\"LINK_M\";a:3:{s:10:\"background\";s:0:\"\";s:5:\"color\";s:0: \"\";s:15:\"text-decoration\";s:0:\"\";}}');
        MySQL Error : Duplicate entry '.alt1, .alt1Active-1' for key 2 Error Number : 1062
        Date : Sunday, April 23rd 2006 @ 05:17:15 PM
        Script :
        http://tourninjas.com/forum/admincp/css.php
        Referrer : http://tourninjas.com/forum/admincp/css.php?do=doedit&dowhat=all&dostyleid=1&group=0
        IP Address : 12.221.176.121
        Username : ninjapete
        Classname : vb_database

        Comment


        • #5
          To troubleshoot this, remove any hacks and disable your plugins, then see if you still have this problem.

          Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

          define('DISABLE_HOOKS', true);

          If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

          Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I am also getting this error message.

            It's when you update a skin using the Search in Templates feature. The template that you then try to edit gets locked and this error message appears.

            Any solutions?

            Comment


            • #7
              Just to confirm This also happens after using Search and Replace on the 'Default Skin'

              Comment


              • #8
                Database error in vBulletin 3.5.4:
                Invalid SQL:
                INSERT INTO template
                (styleid, title, template, template_un, dateline, username, version)
                VALUES
                (12,
                'memberlist',
                'blah blah, I'm not going to post all of this',
                1145890281,
                'Some Username',
                '3.5.4');
                MySQL Error : Duplicate entry 'memberlist-12' for key 2
                Error Number : 1062
                Date : Monday, April 24th 2006 @ 03:51:22 PM
                Script : http://www.somesite.com/forum/admincp/template.php
                Referrer : http://www.somesite.com/forum/adminc....php?do=search
                IP Address : 127.0.0.1
                Username : Some Username
                Classname : vB_Database

                It seemed to happen after I ran a search and replace on all skins. Seems the update step after that hosed the table?

                I can't even update the skins manually now. Just says "do you want to overwrite' and if you click yes it doesn't save.
                Last edited by Matt_270581; Mon 24th Apr '06, 8:13am.

                Comment


                • #9
                  Ok think I found the issue, after using Search and Replace the templates that were edited point to styleid = '-1'

                  Comment


                  • #10
                    Ok, fixed the issue by adding a blank skin and then deleting it. Still, I dunno what the script does but it should do something to refresh all styles properly after editing using the search and replace.

                    Thanks

                    *leaves thread*
                    Last edited by Matt_270581; Mon 24th Apr '06, 8:35am.

                    Comment

                    Loading...
                    Working...
                    X