Announcement

Collapse
No announcement yet.

Character Limit?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Character Limit?

    Hi folks!

    I am re-wording a post I have made a couple of times already just so perhaps someone can understand what my problem is and assist.

    When "Starting a new Thread" is there a character limit for this?

    I am using my vbulletin as a subscription service for Safety Rules and Regulations and some of the topics (Each thread) are in excess of 100 Pages of data which comprise of more than 200,000 characters each.

    I have seen a few people give me their best guess as to what I can change that would help but so far no cigar.

    Perhaps the developer could update the code to make UNLIMITED characters per new topic/post.

    And before you tell me to go to the cpanel, I have already turned everything to unlimited in that.

    It's when I hit "submit new thread" that it just hangs there for 90+ seconds and it times out.

    Thanks,

    John
    Last edited by Safety Admin; Sun 23 Apr '06, 9:23am.

  • #2
    Admin CP -> vBulletin Options -> Message Posting and Editing Options -> Maximum Characters Per Post

    The timeout issue is a PHP configuration problem. The max_execution_time setting is too low to complete this operation.

    To temporarily up your limits edit your includes/config.php file and add this line right under the <?php line:

    ini_set("max_execution_time", "240");

    If you still have this problem, then increase the '240'.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      It's times out because that is a gigantic amount of data to parse, it may only be 190kb of data but does it have any formatting in it?
      Scott MacVicar

      My Blog | Twitter

      Comment


      • #4
        I copy and paste from word which is the original text files. I will try what Steve suggested with the ini_set("max_execution_time", "240"); and let you all know what happens.

        Comment


        • #5
          Well, I have tried as Steve suggested but that did not help. I even changed the value to 5000 with no luck. Any other ideas?

          Thanks

          Comment


          • #6
            Then something else on your server is cusing this. Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

            Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Ok, I did as you asked here is the link

              http://nsie.org/encrypted

              Comment


              • #8
                One other possiblity is the 'post_max_size' setting. Try increasing this to 32M.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Is that also in the config.php?

                  Comment


                  • #10
                    No, it's in php.ini.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Steve,

                      Is there a chance I can give you my server info and vb admin info and let you log in and look? I really have no idea what I am doing and think you could probally do this with your eyes closed.

                      Comment


                      • #12
                        Generally we do not like to mess with server applications and files because if something goes wrong we do not want to be responsible, You need to ask your host to do this.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Alright...

                          So I will call my host and ask them to change the

                          'post_max_size' to 32M

                          How about the "max_execution_time" in lieu of the 'temporary'
                          ini_set("max_execution_time", "5000");

                          Is there a way to change that in the php.ini so that I can take that code out of the config.php?

                          Thanks for all your help Steve.. I really appreciate it

                          John

                          Comment


                          • #14
                            Ok, well I called Startlogic and they said that the server that this account is on is shared with 600 other customers and thus they 'refuse' to modify anthing in the php.ini... My option is going with a Virtual Server, and then I have control over everything... Which is what I think I am going to do... I'll follow up with you in a couple of days when they get this all setup for me.

                            Thanks again Steve!

                            John

                            Comment


                            • #15
                              Hmmm...it may be that you are asking too much for the seerver and hosting plan you are on. You can try adding this to your config.php temporarily to see if this resolves this problem:

                              ini_set("'post_max_size", "32M");
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              Loading...
                              Working...
                              X